geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: Database Pool Deploy Failing
Date Wed, 23 Apr 2008 22:06:07 GMT
Could you try using the wizard to generate a plan, but then deploying  
the pool using the command line (or gshell)?  Also, you may find more  
information in the shell window you started geronimo in -- the admin  
console does not always log all the errors, sometimes they escape into  
System.out.

thanks
david jencks

On Apr 23, 2008, at 3:29 AM, John wrote:

> Hi,
>
> I'm trying to deploy a database connection pool in Geronimo 2.1  
> running on linux under JDK 1.6.  I'm setting up a basic connection  
> pool for PostgreSQL 8.1.x and had the Database Pool Wizard download  
> the appropriate driver.  I then set up the database parameters and  
> performed a successful connection test.  However, when I deploy the  
> connection pool using a database pool name of "jdbc/ 
> PoolName" (without the quotes), I get the following error:
>
> Error Deploying: Unable to deploy: jdbc/PoolName - see the log for  
> details
>
> When I checked the log files, I don't see any reason why the  
> deployment failed.  After, changing the log level to DEBUG and  
> attempting the deployment once again, I produced the following log  
> file:
>
> 05:20:41,397 DEBUG [AuthenticatorBase]  Calling  
> hasUserDataPermission()
> 05:20:41,397 DEBUG [AuthenticatorBase]  Calling authenticate()
> 05:20:41,397 DEBUG [FormAuthenticator] Already authenticated 'system'
> 05:20:41,398 DEBUG [AuthenticatorBase]  Calling accessControl()
> 05:20:41,398 DEBUG [AuthenticatorBase]  Successfully passed all  
> security constraints
> 05:20:41,404 DEBUG [ManagerBase] Start expire sessions  
> StandardManager at 1208946041404 sessioncount 0
> 05:20:41,405 DEBUG [ManagerBase] End expire sessions StandardManager  
> processingTime 1 expired sessions: 0
> 05:20:41,477 DEBUG [CoyoteAdapter]  Requested cookie session id is  
> 9A814535D7EC3D4C18A908B6DD34C6B2
> 05:20:41,477 DEBUG [AuthenticatorBase] Security checking request  
> GET /console/favicon.ico
> 05:20:41,477 DEBUG [AuthenticatorBase] We have cached auth type FORM  
> for principal org.apache.geronimo.tomcat.JAASTomcatPrincipal@1fc6f6a
> 05:20:41,477 DEBUG [AuthenticatorBase]  Not subject to any constraint
> 05:20:41,545 INFO  [SupportedModesServiceImpl] Portlet mode 'edit'  
> not found for portletId: '/system-database.DBWizard!1134683811|0'
>
> It seems like I'm doing this correctly, am I missing something  
> obvious?
>
> Thanks,
> John


Mime
View raw message