geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kevan Miller" <kevan.mil...@gmail.com>
Subject Re: Geronimo WTP client for eclipse , server cannot start
Date Tue, 04 Mar 2008 04:06:44 GMT
On Mon, Mar 3, 2008 at 7:10 PM, CG <learn.koa@gmail.com> wrote:

> On the Console tab, it is started.
> but in on the "Servers" tab , it is starting
>
> However, I can still access localhost:8080 a few seconds after the
> "Geronimo Application Server started" message appear


Thanks for the info. So, it seems your server is starting fine. However,
eclipse is not recognizing this and is timing out the server startup (and
killing the server).

I believe you can configure the server startup parameters. When I double
click on the server when in the "Java EE" perspective, I get a Server
Overview. Part of this overview is "Server Startup" with Ping Delay, Ping
Interval, and Maximum Pings. You could make this timeout essentially
infinite. However, I doubt that you'll be able to do anything useful with
the server from Eclipse (it will probably wait for the server to start
before deploying apps, etc.

Hoping that Tim, or someone else familiar with GEP, can comment on how the
plugin detects server startup.

GShell detects server startup, also. Is that working for you? When you start
the server from a terminal window using either 'gsh geronimo/start-server'
or the 'startserver' shell script, do you see the following displayed as the
final output?

Geronimo Application Server started
Geronimo Server started in 0:00:32.673

 --kevan

Mime
View raw message