geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: GERONIMO 2.1 first impressions, different defects
Date Sun, 02 Mar 2008 23:22:28 GMT

On Mar 2, 2008, at 11:15 AM, fp wrote:

>
> I tried the new GEronimo 2.1.
>
> As in Release note (GERONIMO-3545) Upgrade Apache Derby to  
> 10.3.1.4. but
> only 10.2.2.0 in Repository.
> The derby Data pool Creator in the Webconsole does't show the derby  
> driver
> jars, so it's not possible to create an deployment plan fpr derby  
> there (but
> for other databases!).

When I try (with 2.1.1-SNAPSHOT) I see the system-database plugin  
available to choose, which is what you should do.  If you try to use  
the derby jar directly you will find it gets into severe classloading  
difficulties.  Do you see the system-database plugin?  I haven't  
thought of an efficient non-annoying way to provide instructions for  
this case.

>
> Third question: how to expose the Geronimo Repository as an Plugin.
> Before Geronimo 2 it was just
> http://<host>/console-standard/maven-repo/geronimo-plugins.xml.
> The maven-repo Servlet is still there, but now I get errors?

  Again using 2.1.1-SNAPSHOT the plugins page http://localhost:8080/ 
console/portal/Applications/Plugins indicates that you should try  
something like
http://geronimo-server:8080/plugin/maven-repo/

and on my machine

http://localhost:8080/plugin/maven-repo/geronimo-plugins.xml
works.

Are you seeing something different?  Am I missing something?

thanks
david jencks


>
> -- 
> View this message in context: http://www.nabble.com/GERONIMO-2.1- 
> first-impressions%2C-different-defects-tp15791778s134p15791778.html
> Sent from the Apache Geronimo - Users mailing list archive at  
> Nabble.com.
>


Mime
View raw message