geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jarek Gawor" <jga...@gmail.com>
Subject Re: Installing Apache Solr into Geronimo
Date Thu, 06 Mar 2008 21:56:17 GMT
I'm not 100% sure but this might be a problem in Geronimo somewhere.

The web.xml contains a proper UTF-8 byte-order mark
(http://en.wikipedia.org/wiki/Byte_Order_Mark) and Geronimo should be
able to understand that. Here are the first 16 bytes of this web.xml
in hex (the first 3 bytes is the BOM):

00000000: efbb bf3c 3f78 6d6c 2076 6572 7369 6f6e  ...<?xml version

Jarek

On Thu, Mar 6, 2008 at 4:39 PM, Kevan Miller <kevan.miller@gmail.com> wrote:
>
>  On Mar 6, 2008, at 1:20 PM, tglawles wrote:
>
>  >
>  > I came ot a similar conclusion about 5 minutes ago.  I imported the
>  > WAR into
>  > eclipse and found an error in the web.xml.  It appears to be an
>  > encoding
>  > issues on the first line....
>  >
>  > <?xml version="1.0" encoding="UTF-8"?>
>  >
>  > There is an unseen character before the "<" character which I
>  > deleted.  Once
>  > removed, solr deploys just fine.
>  >
>  > Thanks for help Jason.
>
>  Tom and Jason,
>  Nice work. Thanks for tracking this down. Tom, will you feed this
>  information back to the Solr community?
>
>  It would be nice if Geronimo had a slightly more user-friendly error
>  message than:
>
>
>  Caused by: org.apache.xmlbeans.XmlException: error: Unexpected element:
>  CDATA
>
>  Not a bad idea to track this with a Jira, if you'd like to open one.
>
>  --kevan
>
>

Mime
View raw message