geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josue Barrios Rodriguez" <jbarr...@syc.com.co>
Subject Deploy simple servlet
Date Sat, 01 Mar 2008 15:05:09 GMT
Hi everyone... i need help again.. i'm trying to deploy a simple servlet over geronimo 2.1
and want to parametrize it by web.xml, but when i deploy it error appears and i dont know
why

Error parsing web.xml for .
org.apache.geronimo.common.DeploymentException: Error parsing web.xml for .
at org.apache.geronimo.tomcat.deployment.TomcatModuleBuilder.createModule(TomcatModuleBuilder.java:193)
....
.....
.......

error: cvc-complex-type.2.4a: Expected elements 'run-as@http://java.sun.com/xml/ns/javaee
security-role-ref@http://java.sun.com/xml/ns/javaee' instead of 'init-param@http://java.sun.com/xml/ns/javaee'
here in element servlet@http://java.sun.com/xml/ns/javaee

error: cvc-complex-type.2.4a: Expected elements 'run-as@http://java.sun.com/xml/ns/javaee
security-role-ref@http://java.sun.com/xml/ns/javaee' instead of 'init-param@http://java.sun.com/xml/ns/javaee'
here in element servlet@http://java.sun.com/xml/ns/javaee

error: cvc-complex-type.2.4a: Expected elements 'run-as@http://java.sun.com/xml/ns/javaee
security-role-ref@http://java.sun.com/xml/ns/javaee' instead of 'init-param@http://java.sun.com/xml/ns/javaee'
here in element servlet@http://java.sun.com/xml/ns/javaee

the web.xml file is this...

<?xml version = '1.0' encoding = 'windows-1252'?>
<web-app xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee
http://java.sun.com/xml/ns/j2ee/web-app_2_4.xsd" version="2.4" xmlns="http://java.sun.com/xml/ns/j2ee">
    <servlet>
        <servlet-name>infosyceimg</servlet-name>
        <servlet-class>com.syc.servicios.infosyceimg</servlet-class>
  <load-on-startup>1</load-on-startup>
  <init-param>
        <param-name>rutaBase</param-name>
        <param-value>F:/INFOSYCE_IMG</param-value>
     </init-param>
  <init-param>
        <param-name>imgNoexiste</param-name>
        <param-value>F:/INFOSYCE_IMG/inexi.JPG</param-value>
     </init-param>
  <init-param>
        <param-name>imgDesconexion</param-name>
        <param-value>C:/error.JPG</param-value>
     </init-param>
    </servlet>
    <servlet-mapping>
        <servlet-name>infosyceimg</servlet-name>
        <url-pattern>/*</url-pattern>
    </servlet-mapping>
    
</web-app>


i hope can help me please...

Thanks in advance
______________________

Ing. Josue Barrios Rodríguez
Ingeniero Desarrollador - Sistemas y Computadores S.A.
Centro Empresarial Chicamocha - Oficina 303 Sur
Mobil. 3005610404
Mime
View raw message