geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim McConnell <tim.mcco...@gmail.com>
Subject Re: Geronimo WTP client for eclipse , server cannot start
Date Tue, 04 Mar 2008 14:30:17 GMT
Hi again CG, would you be able to try the same thing that seleshmaster did ?? 
i.e., Namely start with a fresh installation of eclipse and WTP ? If so, you can 
use the ant script on the website listed earlier to download everything you need 
automatically. Plus it only takes a few minutes. Otherwise, please attach the 
configuration details for you Eclipse installation. You can get this from 
Eclipse via Help --> About Eclipse SKD --> Configuration Details. From this data 
we can see what features and plugins you actually have installed and we can then 
try to figure out what exactly you're missing. Thanks much....

CG wrote:
> Tested with the GEP 2.1 unstable.
> No luck , same problem.
> 
> Trying change the ping delay to a big number , the server keep showing
> starting status
> 
> 
> On Tue, Mar 4, 2008 at 7:23 PM, CG <learn.koa@gmail.com> wrote:
>> Hi Tim,
>>   In fact,  I am using GEP 2.0. I thought it should be compatible to
>>  certain extend , at least.
>>  I'll download the unstable version to have a try again. Thanks
>>
>>  CG
>>
>>
>>
>>  On Tue, Mar 4, 2008 at 7:13 PM, Tim McConnell <tim.mcconne@gmail.com> wrote:
>>  > Hi seleshmaster and CG, are you both sure that you have all the WTP prereqs
>>  >  required for the Geronimo Eclipse plugin as listed here ??
>>  >
>>  >  -----> http://geronimo.apache.org/development-tools.html
>>  >
>>  >  Also, if you are using the Geronimo Eclipse Plugin version 2.1.0, where are
you
>>  >  getting it ?? Or are you building it yourself ?? The latest GEP 2.1.0 can
be
>>  >  downloaded from our unstable site at:
>>  >
>>  >  ----->
>>  >  http://people.apache.org/dist/geronimo/eclipse/unstable/geronimo-eclipse-plugin-2.1.0-SNAPSHOT-deployable.zip
>>  >
>>  >  Finally, if you do in fact have all the prereqs installed, could you please
>>  >  attach the log from your Eclipse workspace after the failure occurs ?? It
will
>>  >  be the .log file in your .metadata subdirectory. Thanks much....
>>  >
>>  >
>>  >
>>  >
>>  >  seleshmaster wrote:
>>  >  > Hello;
>>  >  >
>>  >  > I am also a newbie to JEE, I am having a similar problem.  Though, i
can
>>  >  > start the server on command line but I am unable to start the server
in
>>  >  > eclipse. I have setup Geronimo WTP client.
>>  >  > The version I am running is v2.1 (Geronimo).  I was just following the
>>  >  > "5-minute Tutorial on Enterprise Application ..."
>>  >  >
>>  >  > it seems it starts ok, then it just dies
>>  >  >
>>  >  > The error i am getting is " Server Apache Geronimo v2.0  failed to start"
>>  >  >
>>  >  > please help
>>  >  >
>>  >  > thx
>>  >  >
>>  >  >
>>  >  >
>>  >  > CG-6 wrote:
>>  >  >> Hi, I am newbie in Geronimo, or more exactly , newbie in J2EE.
>>  >  >> I have setup the Geronimo WTP client for eclipse , and when I try
to
>>  >  >> start the server it could not start.
>>  >  >>
>>  >  >> Environment
>>  >  >> ==========
>>  >  >> OS is Ubuntu 7.10
>>  >  >> Geronimo version is geronimo-tomcat6-jee5-2.0.1
>>  >  >> Ecplise SDK version is 3.3.1
>>  >  >> JDK version is java_ee_sdk-5_04-linux
>>  >  >>
>>  >  >>
>>  >  >> I have tried to google for solution but could not find relevant answer.
>>  >  >>
>>  >  >> I also tried to run geronimo from cli , using the startup.sh , but
>>  >  >> seems like encounter the same problem.
>>  >  >>
>>  >  >> Hope that somebody can give some guidance to solve this problem.
Thanks.
>>  >  >>
>>  >  >>
>>  >  >>
>>  >  >> Error messages are as below
>>  >  >> ==============================
>>  >  >>
>>  >  >> 22:18:15,725 ERROR [GBeanInstanceState] Error while starting; GBean
is
>>  >  >> now in the FAILED state:
>>  >  >> abstractName="org.apache.geronimo.configs/j2ee-system/2.0.1/car?configurationName=org.apache.geronimo.configs/j2ee-system/2.0.1/car"
>>  >  >> org.apache.geronimo.kernel.repository.MissingDependencyException:
>>  >  >> Unable to resolve dependency
>>  >  >> org.apache.geronimo.modules/geronimo-common/2.0.1/jar
>>  >  >>      at
>>  >  >> org.apache.geronimo.kernel.config.ConfigurationResolver.resolve(ConfigurationResolver.java:114)
>>  >  >>      at
>>  >  >> org.apache.geronimo.kernel.config.Configuration.buildClassPath(Configuration.java:404)
>>  >  >>      at
>>  >  >> org.apache.geronimo.kernel.config.Configuration.createConfigurationClasssLoader(Configuration.java:321)
>>  >  >>      at
>>  >  >> org.apache.geronimo.kernel.config.Configuration.<init>(Configuration.java:266)
>>  >  >>      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native
Method)
>>  >  >>      at
>>  >  >> sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
>>  >  >>      at
>>  >  >> sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
>>  >  >>      at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
>>  >  >>      at
>>  >  >> org.apache.geronimo.gbean.runtime.GBeanInstance.createInstance(GBeanInstance.java:946)
>>  >  >>      at
>>  >  >> org.apache.geronimo.gbean.runtime.GBeanInstanceState.attemptFullStart(GBeanInstanceState.java:268)
>>  >  >>      at
>>  >  >> org.apache.geronimo.gbean.runtime.GBeanInstanceState.start(GBeanInstanceState.java:102)
>>  >  >>      at
>>  >  >> org.apache.geronimo.gbean.runtime.GBeanInstance.start(GBeanInstance.java:539)
>>  >  >>      at
>>  >  >> org.apache.geronimo.kernel.basic.BasicKernel.startGBean(BasicKernel.java:361)
>>  >  >>      at
>>  >  >> org.apache.geronimo.kernel.config.ConfigurationUtil.loadBootstrapConfiguration(ConfigurationUtil.java:195)
>>  >  >>      at
>>  >  >> org.apache.geronimo.kernel.config.ConfigurationUtil.loadBootstrapConfiguration(ConfigurationUtil.java:159)
>>  >  >>      at
>>  >  >> org.apache.geronimo.kernel.util.MainConfigurationBootstrapper.loadBootConfiguration(MainConfigurationBootstrapper.java:84)
>>  >  >>      at
>>  >  >> org.apache.geronimo.kernel.util.MainConfigurationBootstrapper.getMain(MainConfigurationBootstrapper.java:57)
>>  >  >>      at
>>  >  >> org.apache.geronimo.kernel.util.MainConfigurationBootstrapper.main(MainConfigurationBootstrapper.java:38)
>>  >  >>      at org.apache.geronimo.cli.AbstractCLI.executeMain(AbstractCLI.java:67)
>>  >  >>      at org.apache.geronimo.cli.daemon.DaemonCLI.main(DaemonCLI.java:30)
>>  >  >> java.lang.IllegalStateException: GBean is not running:
>>  >  >> org.apache.geronimo.configs/j2ee-system/2.0.1/car?configurationName=org.apache.geronimo.configs/j2ee-system/2.0.1/car
>>  >  >>      at
>>  >  >> org.apache.geronimo.kernel.basic.BasicKernel.getGBean(BasicKernel.java:304)
>>  >  >>      at
>>  >  >> org.apache.geronimo.kernel.config.ConfigurationUtil.loadBootstrapConfiguration(ConfigurationUtil.java:197)
>>  >  >>      at
>>  >  >> org.apache.geronimo.kernel.config.ConfigurationUtil.loadBootstrapConfiguration(ConfigurationUtil.java:159)
>>  >  >>      at
>>  >  >> org.apache.geronimo.kernel.util.MainConfigurationBootstrapper.loadBootConfiguration(MainConfigurationBootstrapper.java:84)
>>  >  >>      at
>>  >  >> org.apache.geronimo.kernel.util.MainConfigurationBootstrapper.getMain(MainConfigurationBootstrapper.java:57)
>>  >  >>      at
>>  >  >> org.apache.geronimo.kernel.util.MainConfigurationBootstrapper.main(MainConfigurationBootstrapper.java:38)
>>  >  >>      at org.apache.geronimo.cli.AbstractCLI.executeMain(AbstractCLI.java:67)
>>  >  >>      at org.apache.geronimo.cli.daemon.DaemonCLI.main(DaemonCLI.java:30)
>>  >  >>
>>  >  >>
>>  >  >
>>  >
>>  >  --
>>  >  Thanks,
>>  >  Tim McConnell
>>  >
>>
> 

-- 
Thanks,
Tim McConnell

Mime
View raw message