geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From newbie-gero <chongm...@e7tech.com>
Subject Cant find the resource-ref even when i have enter it in geronimo-web.xml. is iit a bug or my mistake on my part?
Date Fri, 28 Mar 2008 08:24:44 GMT

Hi lists,
i'm trying out an ejb from the jboss to geronimo.
I have follow the steps as list in :
http://cwiki.apache.org/GMOxDOC21/jboss-to-geronimo-jdbc-migration-unverified-on-21.html

I have deploy the database pool by command line.
This is the my text in geronimo-web.xml
<?xml version="1.0" encoding="ISO-8859-1"?>
<web-app xmlns="http://geronimo.apache.org/xml/ns/j2ee/web-1.1"
xmlns:naming="http://geronimo.apache.org/xml/ns/naming-1.1">
	<dep:environment
xmlns:dep="http://geronimo.apache.org/xml/ns/deployment-1.1">
		<dep:moduleId>
			<dep:groupId>MusicApp</dep:groupId>
			<dep:artifactId>MySqlDS</dep:artifactId>
			<dep:version>2.0</dep:version>
			<dep:type>car</dep:type>
		</dep:moduleId>
		
		<dep:dependencies>
			<dep:dependency>
				<dep:groupId>user</dep:groupId>
				<dep:artifactId>jdbcdatasource</dep:artifactId>
				<dep:version>2.0</dep:version>
				<dep:type>car</dep:type>
			</dep:dependency>
		</dep:dependencies>
		
	</dep:environment>
	<context-root>music</context-root>
	
	<resource-ref>
		
		<ref-name>jdbc/MusicDB</ref-name>
		
		<resource-link>MusicDS</resource-link>
		
	</resource-ref>
	
</web-app>

Please do take note that i have list the resource-ref mapping in
geronimo-web.xml. However i still cant deploy due to these errors it prompt
me

java -jar bin/deployer.jar --user system --password manager deploy
MusicApp.ear
    Error: Unable to distribute MusicApp.ear: Unable to resolve resource
    reference 'jdbc/MusicDB' (Could not auto-map to resource.  Try
    adding a resource-ref mapping to your Geronimo deployment plan.

    Search conducted in current module and dependencies:

    [ALL: org.apache.geronimo.configs/j2ee-server//car]

    [ALL: org.apache.geronimo.configs/openejb//car]

    [ALL: org.apache.geronimo.configs/system-database//car]

    [ALL: org.apache.geronimo.configs/tomcat6//car]

    [ALL: org.apache.geronimo.configs/openjpa//car]

    [ALL: org.apache.geronimo.configs/axis//car]

    [ALL: org.apache.geronimo.configs/axis2//car]

    [ALL: org.apache.geronimo.configs/j2ee-corba-yoko//car]

Is that a bug or it is my mistake on my part

Please advise

-- 
View this message in context: http://www.nabble.com/Cant-find-the-resource-ref-even-when-i-have-enter-it-in-geronimo-web.xml.-is-iit-a-bug-or-my-mistake-on-my-part--tp16347684s134p16347684.html
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.


Mime
View raw message