geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Victorious <>
Subject Default servlet not found?
Date Thu, 20 Mar 2008 04:29:47 GMT


This has been bugging me for half a day now. I hope someone can help me!

I've successfully deployed a .WAR application, it is mapped to /
As a result, images etc. wouldn't load, as they were redirected to the
servlet as well. So I added mappings for *.jpg, *.png, etc. to the servlet
'default'. I also did this in the past with a different Geronimo

The problem:
When deploying, i get the following error:
Unable to deploy: Web app default/OmikronApplication/1205986793250/war
contains a servlet mapping that refers to servlet 'default' but no such
servlet was found!

Things I tried:
If I remove web.xml altogether, the directory listings work fine. If i leave
out the *.jpg, *.png, etc. mappings, the servlet works (but without loading
those images ofcourse). I have also tried
org.mortbay.jetty.......DefaultServlet (I use the Jetty version) instead of
'default', but to no avail. I also noticed that I do NOT have a
web-default.xml or webdefault.xml in my Geronimo folders. Is this correct? I
verified my downloaded archive and it turned out correct.

The geronimo-web.xml and web.xml are listed below.

Thanks in advance!!


<?xml version="1.0" encoding="UTF-8"?>

<web-app version="2.4"


<display-name>Omikron server application</display-name>

	<display-name>Omikron server core</display-name>











<web-app xmlns="">

View this message in context:
Sent from the Apache Geronimo - Users mailing list archive at

View raw message