On Feb 28, 2008, at 9:47 AM, Burt Prior wrote:


Hi David and Jacek,

If you install this in your geronimo repo you should be able to get  past
this problem.

Excellent.  Could you point me to what I need to install?  Is it in
subversion repo?  

cd <geronimo-home>
mkdir -p repository/org/apache/geronimo/modules/geronimo-persistence-jpa10/2.2-SNAPSHOT
wget http://people.apache.org/repo/m2-snapshot-repository/org/apache/geronimo/modules/geronimo-persistence-jpa10/2.2-SNAPSHOT/geronimo-persistence-jpa10-2.2-20080228.021634-2.jar 
mv geronimo-persistence-jpa10-2.2-20080228.021634-2.jar    repository/org/apache/geronimo/modules/geronimo-persistence-jpa10/2.2-SNAPSHOT/geronimo-persistence-jpa10-2.2-SNAPSHOT.jar 

then edit var/config/artifact_aliases.properties

add lines

org.apache.geronimo.modules/geronimo-persistence-jpa10//jar=org.apache..geronimo.modules/geronimo-persistence-jpa10/2.2-SNAPSHOT/jar
org.apache.geronimo.modules/geronimo-persistence-jpa10/2.1/jar=org.apache.geronimo.modules/geronimo-persistence-jpa10/2.2-SNAPSHOT/jar

I have a lot of trouble writing directions that can be followed, so don't be shy about complaining :-)
hmmm.... we need console and gshell actions to upgrade an artifact from a known handy repo such as the apache snapshot repo...

GERONIMO-3884

thanks
david jencks


Do I still need to have Hibernate patched (correctly) to avoid the NPE?

I'm trying to run thru the exact setup steps I need to do on Geronimo to get
it working.

Thanks,
.Burt



djencks wrote:


On Feb 27, 2008, at 6:01 PM, Jacek Laskowski wrote:

On Wed, Feb 27, 2008 at 5:51 PM, David Jencks  
<david_jencks@yahoo.com> wrote:

 did you complain about this on the lists when you found the problem?

Complain? No, not at all. Just put a note with other stuff and it
might not get enough attention. See
http://www.nabble.com/forum/ViewPost.jtp?post=13785778.

I even remember reading that post :-(

Anyway I think it's fixed now and I pushed the jar for trunk....    
org/apache/geronimo/modules/geronimo-persistence-jpa10/2.2-SNAPSHOT/ 
geronimo-persistence-jpa10-2.2-20080228.021634-2.jar
to the apache snapshot repo.

If you install this in your geronimo repo you should be able to get  
past this problem.  It might be simpler to name it geronimo- 
persistence-jpa10-2.1.jar although it would be better to keep its  
real name and put it in the right place and if necessary use an  
artifact_alias entry to get geronimo to find it.

entries would look like
org.apache.geronimo.modules/geronimo-persistence-jpa10// 
jar=org.apache.geronimo.modules/geronimo-persistence-jpa10/2.2- 
SNAPSHOT/jar
org.apache.geronimo.modules/geronimo-persistence-jpa10/2.1/ 
jar=org.apache.geronimo.modules/geronimo-persistence-jpa10/2.2- 
SNAPSHOT/jar

hope this helps
david jencks



Jacek

-- 
Jacek Laskowski
http://www.JacekLaskowski.pl





-- 
View this message in context: http://www.nabble.com/Geronimo-2.1-and-Seam-tp15621154s134p15741951.html
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.