Shiva Kumar H R wrote:

On Fri, Feb 22, 2008 at 4:59 PM, Shiva Kumar H R <> wrote:

On Fri, Feb 22, 2008 at 3:46 PM, Peter Petersson <> wrote:
Hi Jim

I assume you are trying to install liferay in geronimo and not just generate a new plan, with you do not need to, as Shiva have provided you with one (the geronimo-web.xml).

Aside from the security dependency issue you have that I hope **someone else** that are more familiar with the security (dependency) changes done between G v2.0.2 and v2.1 will help you with, there are a couple of more things to do:

As the liferay-portal-geronimo-tomcat car is dependent (if you haven't changed the geronimo-web.xml regarding the db pool) on the liferay-portal-geronimo-derby-pool car, so to successfully install the liferay-portal-geronimo-tomcat car you have to install the derby pool **before** the liferay-portal-geronimo-tomcat car.
After a smal tweak of the META-INF/geronimo-plugin.xml included in the derby-pool car file you should be able to install the db pool by issuing
deploy --user <user> --password <passoword> install-plugin <derby pool car file>
The geronimo-plugin.xml tweak consist of changing the version tag in the geronimo-plugin.xml to <version>2.1-SNAPSHOT</version> (omit -snapshot for released geronimo). The same command (as above) can then be used on the liferay-portal-geronimo-tomcat car (when the security dependency issue is fixed)

Looks like there is more to it than just that. I have been trying it since yesterday and it is failing with below error:

Installation FAILED: A plugin configuration must include one plugin artifact, not 0

Alright this is now solved :) . Update the geronimo-plugin.xml inside with the one attached here.

(The schema for geronimo-plugin.xml has changed and I have updated it accordingly by looking at other examples.)
ahh, yes now I remember it was more to it than just the version it was a couple of weeks ago I messed around with the pool and it slipped my mind, good to here you solved it.
   peter petersson
Now let me deploy liferay-portal-4.4.1.war using the plan provided by DJencks.


Any idea where is the source for ?

Maybe this link will be of some help to you even though it is a bit outdated

  peter petersson


Jim Foster wrote:
Shiva Kumar H R wrote:
There are two problems, both in Plan Creator feature:
1) Error message/Java Exceptions are suppressed by Plan Creator code and
shown to the user at all :-(

With liferay-portal-4.4.1.war, when I ran Geronimo in debug mode and
connected via Eclipse (with a break point put at the beginning of
function inside "plancreator-portlets" module), I found that we are
following exception:

org.apache.geronimo.common.DeploymentException: AbstractWebModuleBuilder:
Could not load servlet class: com.liferay.portal.servlet.MainServlet

Instead of showing this error on Console, plan creator is currently
suppressing it in an empty catch() block.
*is opened for this.

2) Secondly, I see that the class it is complaining "
com.liferay.portal.servlet.MainServlet" *does* exist, but inside a
compressed jar ("portal-impl.jar") in WEB-INF/lib directory of WAR. Plan
Creator has a current limitation :-( in resolving such classes. *
GERONIMO-3851 <> *is
opened for this.

Due to these bugs/limitations, I am sorry to say that you will again have
create geronimo-web.xml by hand. I found one "geronimo-web.xml" inside
liferay-portal-4.4.1.war itself. I have removed non-existing dependencies
from it and attached it in this mail. Please see if it works. (I guess it
requires some pre-requisite db-pools to be deployed before the WAR can be
deployed). Hope it helps.


Hi Shiva,

Is there any new word on the origins of the security configuration errors we
were seeing?

I have spent a good deal of time this week reading everything I could get my
hands on, including a healthy chunk of the 120 Geronimo articles up at IBM's

However, the most recent I could find that seemed relevant to this issue was
on the wiki:

However, this is an installation document, and provides little in the way of
debugging guidelines, and I  am only now just far enough along in wrapping
my head around all the technologies that make up Geronimo to get myself in


Once past this, I would like your advise on how to bring up to date the
Liferay-provided .car file for the derby pool. I looked at its contents, and
I see that they are clearly wrong (my guess is that they were written for
v1.1), but I am not quite sure how to go about fixing it so as to be in
alignment with v2.1 step at a time though...first the security issue.

Thank you for your time, patience, and advise.