geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: (Please Reply) Facing problem while running servicemix sample on Geronimo
Date Fri, 15 Feb 2008 20:24:19 GMT
I'd guess that either the TLD files are not valid or that they are  
not for the latest schema and our upgrade process has a bug.  If we  
know the tld file and the error it should be pretty easy to figure  
out which.

thanks
david jencks

On Feb 15, 2008, at 12:10 PM, Jay D. McHugh wrote:

> Puneet,
>
> Could you try testing this on vanilla Tomcat 6.0.14?
>
> When I try deploying on Geronimo, I get several errors concerning  
> the validation of TLD files.
>
> I also get a couple of exceptions that some postings on the  
> ServiceMix mail list say should not be an issue.
>
> But, on Tomcat, I only get the exceptions (the ones that supposedly  
> are not an issue) - not the validation errors.
>
> Please let me know what you find.  If it turns out that Tomcat  
> works fine, then we can start looking deeper into what Geronimo is  
> doing that Tomcat isn't.
>
> Thanks,
>
> Jay
>
> puneetjain wrote:
>> Hi Jay,
>>
>> Thanks for your reply.
>>
>> Environment Details: =============
>> Application Server - geronimo-tomcat6-jee5-2.0.2
>> ESB - servicemix3.2.1 JDK- Java 1.5
>> Operating System: Redhat Enterprise Linux 4
>>
>> I have performed following steps to deploy servicemix on Geronimo.
>>
>>
>> Steps Performed:
>> ===========
>>
>> 1.  Deployed the Servicemix-web.war, downloaded from the Web  
>> Application
>> section of below link:
>>      http://servicemix.apache.org/download.html
>>
>> 2.  Installed servicemix shared library using the servicemix web  
>> interface's
>> Shared Library Menu.
>> 3.  Installed and started all required servicemix components using  
>> the
>> servicemix web interface's Components Menu.
>> 4.  Deployed and started my sample servicemix service assembly  
>> using the
>> servicemix web interface's Servicemix assembly menu.
>> 5.  I am able to view my service at the following URL:
>>      http://localhost:8080/Servicemix-web/jbi
>>
>> Issue:
>> ====
>> When I access this my service I am not getting the response back  
>> on the
>> browser. I am using In-Out Mep. Mapping is already attached in the  
>> previous mail.
>> I am using a Http Marshaler class in http consumer component. The  
>> sendOut
>> method of my Marshaler class is not getting called.
>>
>> Please help me in resolving this problem, as I am stuck with this  
>> from long
>> time.
>>
>> Thanks,
>> Puneet
>>
>>
>>
>> Jay D. McHugh-3 wrote:
>>
>>> Hi Puneet,
>>>
>>> How did you install ServiceMix on Geronimo?
>>>
>>> Did you use the war file download or did you build ServiceMix  
>>> from source and use the Geronimo plugin?
>>>
>>> Were there any errors/exceptions during deployment of ServiceMix?
>>>
>>>
>>> Jay
>>> puneetjain wrote:
>>>
>>>> Hi,
>>>>
>>>> Any suggestions on this issue. I tried my best and still did not  
>>>> moved
>>>> even
>>>> a bit.
>>>> Please pour your suggestions to solve this petty issue.
>>>>
>>>> I am really struck.
>>>> Thanks,
>>>> Puneet
>>>>
>>>>
>>>> :confused::confused::confused::,(
>>>>
>>>>
>>>>
>>>>
>>>> Hi,
>>>> I am facing problem while running a sample code of servicemix in
>>>> jboss/Geronimo. The sample is running fine with  servicemix  
>>>> stand alone but not working
>>>> when
>>>> deployed on  jboss/Geronimo. What I have observed is that the  
>>>> http consumer is not getting the
>>>> response
>>>> data.
>>>> sendOut() method of MyMarshler is not getting called of my  
>>>> marshler bean
>>>> class.
>>>>
>>>> The response is not getting displayed on the Internet browser.  
>>>> The same
>>>> thing runs fine as standalone application.
>>>> The other details are given below:
>>>>
>>>> Environment: ======== Jboss 4.2.2.GA servicemix3.2.1 Java 1.5
>>>> OS Linux
>>>> Steps Performed: =========== 1. xbean configuration for http- 
>>>> consumer service unit is:
>>>> 	<?xml version="1.0" encoding="UTF-8"?>
>>>>
>>>> 	<beans xmlns:http="http://servicemix.apache.org/http/1.0"
>>>> 	       xmlns:ex="http://www.servicemix.org/example">
>>>> 	  <http:consumer service="ex:httplistener"
>>>> 			 endpoint="ex:listenerEndpoint"
>>>> 			 locationURI="http://0.0.0.0:8192/upload/"
>>>> 			 defaultMep="http://www.w3.org/2004/08/wsdl/in-out"
>>>> 					 targetService="ex:lineReverse"
>>>> 			 marshaler="#marshaler" />
>>>>
>>>> 	  <bean id="marshaler"  
>>>> class="org.apache.servicemix.jbi.MyMarshaler" />
>>>>
>>>> 	</beans>
>>>>
>>>>
>>>> 2. xbean configuration for bean service unit.
>>>> 	<beans xmlns:bean="http://servicemix.apache.org/bean/1.0"  
>>>> 	       xmlns:ex="http://www.servicemix.org/example">
>>>> 	  <bean:endpoint service="ex:lineReverse"  
>>>> endpoint="lineReverseEndpoint"
>>>> bean="#lineReverseBean" /> 	  <bean id="lineReverseBean"  
>>>> class="org.apache.servicemix.jbi.MyBean" />
>>>> 	</beans>
>>>>
>>>>
>>>> Exception: There is no exception raised at all.
>>>> ======
>>>>
>>>>
>>>> Please help me to resolve this. A early response will be highly
>>>> appreciated
>>>> as it is a bottleneck for my work.
>>>>
>>>> Thanks, Puneet Jain
>>>>
>>>>
>>>>
>>>
>>>
>>
>>
>



Mime
View raw message