geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Bohn <joe.b...@earthlink.net>
Subject Re: Geronimo 2.1 not working Pluto Portlet Exception
Date Thu, 28 Feb 2008 14:59:20 GMT
BenLeino wrote:
> Hi,
> 
> I have still the bug in latest Geronimo 2.1 release from 18.02 with the
> pluto portlet exception mentioned here:
> 
> https://issues.apache.org/jira/browse/GERONIMO-3855
> 
> How can I get a working(!) copy of the current 2.1 build of Geronimo? Is
> there any bugfix available?
> 
> Thanks a lot,
> Tim

Hi Tim,

This has been fixed in the current Geronimo trunk (2.2-SNAPSHOT) and the 
branches/2.1 (2.1.1-SNAPSHOT).

If you are running with the Geronimo 2.1 release you can try this as an 
interim measure:

1)  Copy pluto-portal-driver-impl-1.2.0-G601061.jar  from 
http://svn.apache.org/repos/asf/geronimo/server/trunk/repository/org/apache/pluto/pluto-portal-driver-impl/1.2.0-G601061/
to 
<geronimo-install>/repository/org/apache/pluto/pluto-portal-driver-impl/1.2.0-G601061/

   (you will need to create the new directory for 1.2.0-G601061).

2)  Add the following two lines to 
<geronimo-install>/var/config/artifact-aliases.properties :
org.apache.pluto/pluto-portal-driver-impl//jar=org.apache.pluto/pluto-portal-driver-impl/1.2.0-G601061/jar
org.apache.pluto/pluto-portal-driver-impl/1.2.0-G601060/jar=org.apache.pluto/pluto-portal-driver-impl/1.2.0-G601061/jar


HTH,
Joe

Mime
View raw message