geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vamsavardhana Reddy" <c1vams...@gmail.com>
Subject Re: Issue while deploying web app in 2nd instance of geronimo
Date Sat, 09 Feb 2008 17:09:06 GMT
When you create multiple instances by making a copy of var directory, both
the instances still use the same repository.  When you configure an
additional repository for each instance so that the apps deployed won't go
into the common repository, you need to specify the "target" repository at
deployment time.  Deployment from admin console does not support this target
option.  You will need to use the command line deployer.  To see the
available targets in a particular instance, use "deploy --port
RMIPortOfTheInstance --host hostname list-targets".  While deploying the
app, you will have specify target using --target option.  Use "deploy help
deploy" to see the help.

++Vamsi

On Feb 9, 2008 9:24 PM, Peter Petersson <peter@pmb.mine.nu> wrote:

> Hi
> When deploying try use the --port XXXX option to use the port the second
> instance of G is running on, it will probably fix your problem.
> regards
>  Peter P
>
> abpb2006 wrote:
> > Hi,
> >
> > I have 2 intances of Geronimo running (Multiple Instances) :
> >
> > geronimo install (geronimo_server) and under this i have 2 instances
> g_one
> > and g_two.
> >
> > When i start g_one and deploy wep app it gets deployed under g_one's
> deploy
> > directory and this fine but in case when i try to deploy the web app for
> > g_two instance...it using web console...it tires to deploy under
> > geronimo_server's default directory rather thn under g_two.
> >
> > Any pointers?? higly appriciate your help
> >
> > i'm using geronimo 2.x
> >
> >
> >
> >
> >
>
>

Mime
View raw message