geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mett <geron...@romram.se>
Subject Solved! Re: Geronimo WTP client for eclipse doesn't work as expected
Date Wed, 27 Feb 2008 12:55:39 GMT

Hi!

Finally I found the source to the problem. When a project is created within
eclipse, an eclipse that has the Geronimo WTP client installed the Targeted
Runtime is set to Apache Geronimo as a default.

For my project that was created outside eclipse this isn't the case.

After comparing every little detail between these projects I found that
setting Apache Geronimo v2.0 as a targeted Runtime changes was noticed by
Geronimo. Looking back this seems quite obvious, it wasn't for me believe
you me.


over and out! // mett


mett wrote:
> 
> Thanks for all your effort so far Tim,
> 
> However I haven't found the solution yet but I have an hunch on where the
> error might be.
> 
> Since the project is renewed when it is removed from the server via "Add
> and Remove Projects..." menu option but not when the WTP is signaling
> changed files I believe the Geronimo is looking for changed files in the
> wrong place. As I mentioned before the Geronimo Server changes state in
> the Servers view in Eclipse but the console stays the same.
> 
> I believe that the cause for this might be that the project structure
> isn't "default" eclipse but a deeper hierarchy painted by maven. 
> 
> When I create a project within eclipse the change in an jsp or html page
> is instantly reflected in the web browser.
> 
> Is there something in some configuration file that I need to look at.
> Please kick me in the right direction.
> 
> 
> 
> Tim McConnell-2 wrote:
>> 
>> Hi Mett, let me take a stab at your questions.....
>> 
>> 1. You are looking in the right place, but as you know WTP is very large
>> with 
>> many feature and plugins such that the precise version of WTP is somewhat 
>> obfuscated (at least as far as I know). What you may want to consider is
>> to 
>> possibly start with a new Eclipse installation and download what is
>> required to 
>> run the version of the GEP that you wish to use. If you want to use GEP
>> 2.0 you 
>> can get the list of prereqs from here:
>> 
>> ---> http://geronimo.apache.org/development-tools.html
>> 
>> I would recommend just using the ant script since it'll save you a LOT of
>> time 
>> by downloading everything for you (except the JDK), and unzipping it into
>> an 
>> eclipse directory that you can use to create your new eclipse
>> installation. 
>> Also, these are the latest maintenance versions of WTP and the other
>> prereqs. If 
>> you don't want maintenance versions but would rather use official
>> released 
>> versions you can use this ant script instead....
>> 
>> ---> 
>> http://svn.apache.org/repos/asf/geronimo/devtools/eclipse-plugin/tags/2.0.0/eclipse/build.xml
>> 
>> 2. Frankly, I don't know much about the BEA jrockit JDK. It may be fine,
>> but 
>> Geronimo and the GEP are developed and tested only on Sun JDKs, and I
>> would 
>> recommend the same for you just to be safe.
>> 
>> 3. If you following the recommendations in #1, #2 above you will also
>> want to 
>> start with a new Eclipse workspace as well and then define the Geronimo
>> server. 
>> If not, then you definitely need to delete and redefine you Geronimo
>> Server 
>> Definition.
>> 
>> Hope this helps. Thanks.
>> 
>> mett wrote:
>>> Hi Tim,
>>> 
>>> First of all it's really nice to get such a swift response to a question
>>> of
>>> mine, Thanks!
>>> 
>>> However I have a couple of follow up questions:
>>> 
>>> 1. Where is the place to verify the version numbers in Eclipse? When I
>>> look
>>> at Help/About Eclipse Platform/Feature Details I find them all but WTP.
>>> This
>>> is strange to me since I am sure I have installed this. Going further
>>> down
>>> into the Plug-In Details I find a lot of plug-ins starting with the
>>> letters
>>> WTP but then with the wrong version number. I don't even think they are
>>> related to the true WTP.
>>> 
>>> 2. How important is the Sun JDK 5.0? I am running on jrockit 1.6.0_01.
>>> 
>>> 3. Now, after finishing with updates of all updatable plug-ins there are
>>> I
>>> still can't find the WTP plugin in the Feature Details list. I now know
>>> that
>>> this is installed since I just did it (again). Where can I verify its
>>> existance?
>>> 
>>> Within the Plug-in details dialog I find these WTP(?) plugins: WTP EJB
>>> UI
>>> Plug-in, WTP J2EE UI Plug-in, WTP JCA UI Plug-in, WTP Servlet UI
>>> Plug-in,
>>> WTP UI Plug-in, WTP Webservice UI Plug-in. These doesn't seam to be
>>> directly
>>> related but they start with WTP.
>>> 
>>> The IDE is restarted a numerous of times, Do I need to reinstall the
>>> Geronimo server after I updated all of these features?
>>> 
>>> 
>>> Best Regards
>>> 
>>> Mett
>>> 
>>> 
>>> 
>>> 
>>> Tim McConnell-2 wrote:
>>>> Hi Mett, I see the problem on our trunk version of the Geronimo Eclipse
>>>> Plugin 
>>>> (GEP) and Geronimo server. It works fine for me though on my 2.0.2
>>>> version
>>>> of 
>>>> the Geronimo and Plugin. I'm guessing at this point that it might be a
>>>> WTP 
>>>> problem, but will have to do a bit more analysis/debugging to ensure
>>>> that
>>>> is the 
>>>> case. Thanks much for bringing this to our attention....
>>>>
>>>>
>>>> mett wrote:
>>>>> Hi,
>>>>>
>>>>> I am quite new at Geronimo at the moment. I have up to now been using
>>>>> JBoss
>>>>> as an integrated application server in my Eclipse IDE. Since I am all
>>>>> but
>>>>> impressed of the way that server handles memory and redeploy I am
>>>>> interested
>>>>> in trying out the Geronimo application server.
>>>>>
>>>>> The status at the moment is that I have the Geronimo server 2.0.2
>>>>> installed
>>>>> and working. I have a deployment plan that works and I think that the
>>>>> performance is better. 
>>>>>
>>>>> My problem is the automatic redeploy that I can't get to work at all.
>>>>> When I
>>>>> alter an jsp page or a java class the WTP reacts and the server starts
>>>>> a
>>>>> redeploy but there isn't any change in the appearance or the files in
>>>>> the
>>>>> server structure.
>>>>>
>>>>> For a change to have affect I need to remove the project with the Add
>>>>> and
>>>>> Remove Projects... menu option. Restart the server and the add the
>>>>> project
>>>>> again. This is a bit more tedious than using JBoss; to describe it
>>>>> mildly.
>>>>>
>>>>> The action is exactly similar regardless of how the installation has
>>>>> been
>>>>> done. First I installed Geronimo by hand and the WTP from within
>>>>> eclipse.
>>>>> I
>>>>> all worked as above. After that I tried to do also the Geronimo
>>>>> installation
>>>>> from within eclipse. Then I got 2.0.1 with the JRE_HOME issue and
>>>>> upgraded
>>>>> to 2.0.2 with the above result.
>>>>>
>>>>> I am using Maven to set up and manage my projects so the compiled
>>>>> files
>>>>> end
>>>>> up in target/classes if this is an issue.
>>>>>
>>>>> Please guide me, I want to use Geronimo and I refuse to believe that
>>>>> it
>>>>> is
>>>>> intended to work this way.
>>>>>
>>>>>
>>>>> Best Regards
>>>>>
>>>>> Mett
>>>> -- 
>>>> Thanks,
>>>> Tim McConnell
>>>>
>>>>
>>> 
>> 
>> -- 
>> Thanks,
>> Tim McConnell
>> 
>> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Geronimo-WTP-client-for-eclipse-doesn%27t-work-as-expected-tp15131412s134p15712658.html
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.


Mime
View raw message