geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From abpb2006 <abpb2...@yahoo.com>
Subject Re: Issue while deploying web app in 2nd instance of geronimo
Date Wed, 06 Feb 2008 22:02:27 GMT


1. i have geronimo_server and the i copy var oflder from this location
geronimo_server/g_one and geronimo_server/g_tow

2. I changed the rmi port as well so the instance of g_one and g_two start
sarerately on diff port with no conflict

3. I also deployed the saperate repositry of each of these instances

4. When i deploy web app thru g_one instance using web console it gets
deployed fine under g_one/var 

5. But when i try to deploy web app thru g_two using web console it tries to
deploy under geronimo_server/repository/default also it keeps the .war file
under g_tow/var

My undersatdning is sicne there going to be 2 intances then web app deployed
thru one instance shoud go to instance location rather server's location.

Pl suggest






djencks wrote:
> 
> Could you provide more information on exactly what is duplicated and  
> what is shared between your two instances and where you expect the  
> app to be deployed and exactly which files are changed?
> 
> If you've made several copies of var (say g_one/var and g_two/var)  
> and deploy an app to one of these servers using the console I'd   
> expect the app to be deployed into repository (same location no  
> matter which instance you deploy to) but only the */var/config/ 
> config.xml and related files to be updated for the server you are using.
> 
> If you've added an additional repository per-server into */var  
> somewhere then I'm not sure how you would tell the web console to use  
> that repository rather than the "normal" one.
> 
> thanks
> david jencks
> 
> On Feb 5, 2008, at 11:48 PM, abpb2006 wrote:
> 
>>
>> Hi,
>>
>> I have 2 intances of Geronimo running (Multiple Instances) :
>>
>> geronimo install (geronimo_server) and under this i have 2  
>> instances g_one
>> and g_two.
>>
>> When i start g_one and deploy wep app it gets deployed under  
>> g_one's deploy
>> directory and this fine but in case when i try to deploy the web  
>> app for
>> g_two instance...it using web console...it tires to deploy under
>> geronimo_server's default directory rather thn under g_two.
>>
>> Any pointers?? higly appriciate your help
>>
>> i'm using geronimo 2.x
>>
>>
>>
>>
>> -- 
>> View this message in context: http://www.nabble.com/Issue-while- 
>> deploying-web-app-in-2nd-instance-of-geronimo- 
>> tp15306292s134p15306292.html
>> Sent from the Apache Geronimo - Users mailing list archive at  
>> Nabble.com.
>>
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Issue-while-deploying-web-app-in-2nd-instance-of-geronimo-tp15306292s134p15312824.html
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.


Mime
View raw message