geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From puneetjain <puneet.ja...@wipro.com>
Subject Re: facing problem in deploying war file on Geronimo
Date Sat, 02 Feb 2008 11:46:00 GMT

Hi Kevan,

Thanks a lot for your inputs. I tried them and it works fine in windows.

However, when i tried to deploy this same war on a Linux machine (where I
have geronimo) with the same deployment plan using the below command, i
encounter an exception

Environment
========
Operating System : Red Hat Enterprise Linux 3.4
Application Server : Geronimo 2.0.2
Mule : Mule 1.4.3
JDK : 1.5


Steps Performed
===========
./deploy.sh deploy mule-examples.war <deployment-plan-file-name>

Errors Encountered
=============
I am attaching the log file in the mail.

http://www.nabble.com/file/p15242072/deployer.log deployer.log 
http://www.nabble.com/file/p15242072/geronimo.log geronimo.log 
http://www.nabble.com/file/p15242072/geronimo.out geronimo.out 

Please help me.

Thanks,
Puneet Jain




Kevan Miller wrote:
> 
> 
> On Feb 1, 2008, at 2:18 PM, puneetjain wrote:
> 
>>
>> Hi,
>>
>> I am facing a problem while deploying sample mule-examples.war in  
>> Geronimo.
>>
>> Environment:
>> =========
>>
>> Mule 1.4.3
>> Geronimo-tomcat6-jee5-2.0.2
>> JDK 1.5
>> WindowsXP
>>
>> Step Perform:
>> =========
>>
>> 1. I have built the example war file.
>> 2. I have deployed Mule JCA on Geronimo.
>> 3. I m trying to deploy the mule-examples.war file on geronimo is  
>> thorw
>> bellow exception:
>>
>>
>> 23:29:30,672 ERROR [[/PerfTester2]]
>> org.mule.util.StringUtils.defaultIfEmpty(Ljava/lang/String;Ljava/ 
>> lang/String;)Ljava/lang/String;
>> java.lang.NoSuchMethodError:
>> org.mule.util.StringUtils.defaultIfEmpty(Ljava/lang/String;Ljava/ 
>> lang/String;)Ljava/lang/String;
>>
> 
> Hi Puneet,
> You're running into a conflict between different versions of commons- 
> lang jars. Create a deployment plan with the following:
> 
> <?xml version="1.0" encoding="UTF-8"?>
> <web-app xmlns="http://geronimo.apache.org/xml/ns/j2ee/web-1.1"  
> xmlns:dep="http://geronimo.apache.org/xml/ns/deployment-1.1"  
> xmlns:naming="http://geronimo.apache.org/xml/ns/naming-1.1">
>    <dep:environment>
>      <dep:moduleId>
>        <dep:groupId>org.mule</dep:groupId>
>        <dep:artifactId>mule-examples</dep:artifactId>
>        <dep:version>1.4.3</dep:version>
>        <dep:type>car</dep:type>
>      </dep:moduleId>
>      <!--
>           Don't load commons-lang classes from our parent
>        -->
>      <hidden-classes>
>        <filter>org.apache.commons.lang</filter>
>      </hidden-classes>
>    </dep:environment>
> </web-app>
> 
> Then run:
> 
> ./deploy.sh deploy mule-examples.war <deployment-plan-file-name>
> 
> --kevan
> 
> 

-- 
View this message in context: http://www.nabble.com/facing-problem-in-deploying-war-file-on-Geronimo-tp15231880s134p15242072.html
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.


Mime
View raw message