geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mett <geron...@romram.se>
Subject Re: Geronimo WTP client for eclipse doesn't work as expected
Date Fri, 01 Feb 2008 12:04:04 GMT

Hi again Tim,

I have now manually downloaded WTP maintenance build type
http://download.eclipse.org/webtools/downloads/drops/R2.0/M-2.0.2-20080117053217/.
I exported the zip contents to my Eclipse installation folder and restarted
Eclipse Europe.

I still can't find the WTP within the Eclipse IDE.

What is your suggested path for moving on, I really want this to work...


Best Regards

Mett



Tim McConnell-2 wrote:
> 
> Hi Mett, I see the problem on our trunk version of the Geronimo Eclipse
> Plugin 
> (GEP) and Geronimo server. It works fine for me though on my 2.0.2 version
> of 
> the Geronimo and Plugin. I'm guessing at this point that it might be a WTP 
> problem, but will have to do a bit more analysis/debugging to ensure that
> is the 
> case. Thanks much for bringing this to our attention....
> 
> 
> mett wrote:
>> Hi,
>> 
>> I am quite new at Geronimo at the moment. I have up to now been using
>> JBoss
>> as an integrated application server in my Eclipse IDE. Since I am all but
>> impressed of the way that server handles memory and redeploy I am
>> interested
>> in trying out the Geronimo application server.
>> 
>> The status at the moment is that I have the Geronimo server 2.0.2
>> installed
>> and working. I have a deployment plan that works and I think that the
>> performance is better. 
>> 
>> My problem is the automatic redeploy that I can't get to work at all.
>> When I
>> alter an jsp page or a java class the WTP reacts and the server starts a
>> redeploy but there isn't any change in the appearance or the files in the
>> server structure.
>> 
>> For a change to have affect I need to remove the project with the Add and
>> Remove Projects... menu option. Restart the server and the add the
>> project
>> again. This is a bit more tedious than using JBoss; to describe it
>> mildly.
>> 
>> The action is exactly similar regardless of how the installation has been
>> done. First I installed Geronimo by hand and the WTP from within eclipse.
>> I
>> all worked as above. After that I tried to do also the Geronimo
>> installation
>> from within eclipse. Then I got 2.0.1 with the JRE_HOME issue and
>> upgraded
>> to 2.0.2 with the above result.
>> 
>> I am using Maven to set up and manage my projects so the compiled files
>> end
>> up in target/classes if this is an issue.
>> 
>> Please guide me, I want to use Geronimo and I refuse to believe that it
>> is
>> intended to work this way.
>> 
>> 
>> Best Regards
>> 
>> Mett
> 
> -- 
> Thanks,
> Tim McConnell
> 
> 

-- 
View this message in context: http://www.nabble.com/Geronimo-WTP-client-for-eclipse-doesn%27t-work-as-expected-tp15131412s134p15225210.html
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.


Mime
View raw message