Are you trying to use our copy of axis2 or cxf or are you trying to use some jaxws implementation you are supplying yourself?

I think that you may have trouble since AFAIK we are required in java ee  to support jaxws 2.0 which IIUC is not completely compatible with jaxws 2.1.

What I would try is:

remove the axis2-jaxws-api jar to be sure it doesn't get used by mistake :-)
put the jaxws-api-2.1 jar in an appropriate place in the geronimo repo, say com/sun/specs/jaxws-api/2.1/jaxws-api-2.1.jar
add lines to var/config/artifact_aliases.properties mapping the jar we provide to the jar you want:

org.apache.axis2/axis2-jaxws-api//jar=com.sun.specs/jaxws-api/2.1/jar
org.apache.axis2/axis2-jaxws-api/1.3/jar=com.sun.specs/jaxws-api/2.1/jar

This should replace the axis jar with your jar in the jee-specs classloader, and as long as there are no incompatible class changes everything should work.

Hope this helps and please let us know the results

thanks
david jencks


On Jan 29, 2008, at 2:56 PM, Jon wrote:

Hello,
 
I am trying to get an EJB to work correctly within Geronimo.  I seem to be having a classloader issue.  The jaxws-api-2.1 jar is in my EAR file.  I need for my EJB to use the jaxws-api-2.1 jar and not the javax.xml.ws.* classes found in the axis2-jaxws-api module.  The axis2-jaxws-api jar uses older classes that do not support the Service.createDispatch(EndpointReference, JAXBContext, Mode, WebServiceFeature...) method.  I have tried changing the jaxws provider to CXF and still no luck because it seems that they both hit the same underlying jar.  In the 2.0.2 Geronimo build, you can find the jar at {geronimo.home}/repository/org/apache/axis2/axis2-jaxws-api/1.3.  I have tried to incorporate other configuration found in the deployment-1.2 schema including inverse-classloading and hidden-classes (supplying filter javax.xml.ws and javax.xml.ws.spi).  If I drop the jaxws-api-2.1 jar into the Geronimo endorsed dir, it explodes.  If anyone has any suggestions as to how I can get the EJB to work correctly using the jaxws-api 2.1 jar, I would really appreciate it.
 
-Brandon