geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: Spring petclinic sample application (from Srping 2.5.1) on Geronimo 2.0.2?
Date Tue, 29 Jan 2008 21:14:33 GMT
Could you give us more info on exactly where you found this app and  
where the geronimo plan is?  We might want to try to get the plan  
upgraded to a less obsolete version.  The geronimo 1.0 plans were not  
compatible with later geronimo releases.

In geronimo 1.1 we included a plan upgrader, but it seems to have  
disappeared from later geronimo releases.  The simplest way to use it  
is I believe to download a copy of geronimo 1.1 from http:// 
geronimo.apache.org/apache-geronimo-v11-release.html, unpack it, and run

java -jar bin/upgrade.jar <input-plan> <output-plan>

This is less than desirable.... but this is also the first anyone has  
noticed that the upgrader has gone missing.

thanks
david jencks



On Jan 29, 2008, at 12:13 PM, Paul Wong wrote:

> hey all:
>
>
> I am trying to deploy the Spring petclinic sample application (from  
> Srping 2.5.1) on Geronimo 2.0.2 and i get this error:
>
>
> org.apache.geronimo.common.DeploymentException: Cannot handle web plan
>
> with namespace http://geronimo.apache.org/xml/ns/j2ee/web-1.0 --
>
> expecting http://geronimo.apache.org/xml/ns/j2ee/web-2.0.1 or......
>
>
> Any suggestion to get this going?
>
>
> Thanks a lot for your great help.
>
>
> Paul
>
>
>


Mime
View raw message