geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Graham <jcgraham...@hotmail.com>
Subject keystore question
Date Wed, 16 Jan 2008 21:42:44 GMT

Hello,

I'm using a geronimo-based app to connect to an SSL-based LDAP server. When I initially connected
I got an error indicating I needed to add the server's certficate to Geronimo's keystore.
So I used the web interface to do that, and it added the requisite certificate to a file called
"ssl-keystore-1". When I connected again, after restarting my app, I get the same "can't find
valid certification path to requested target". 

I used the linux 'strace' command to examine the system calls the java process was making,
and found it was *not* opening "ssl-keystore-1", but a file called "keystore". So I presume
this is the heart of the problem. After googling a bit, I notice there used to be a keystoreLocation
parameter for geronimo, but I don't have the ability to configure that in my deployment. Likewise,
I tried setting JAVA_OPT= -Djavax.net.ssl.trustStore=<path of ssl-keystore-1>, and restarted
my app. Still the same error, and the java process was still opening up "keystore". 

Does anyone know how to resolve this problem? 

Thanks,
- J o h n

Mime
View raw message