geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevan Miller <kevan.mil...@gmail.com>
Subject Re: Geronimo Deployment goes forever
Date Tue, 22 Jan 2008 17:16:16 GMT

On Jan 22, 2008, at 11:27 AM, gersek wrote:

>
> David,
>  Thanks for your suggestion, I moved geronimo and my workspace to c  
> drive.
> I got the same problem.
>
> I have attached the ear file  and not able to attache my  
> workspace(it is
> around 20mb).

Thanks Sekhar.

Your ClassNotFoundException is causing the deploy to hang. The fact  
that the deploy is never completing is a Geronimo bug -- see  https://issues.apache.org/jira/browse/GERONIMO-3767

Rather than using the console, you could use the command line tool to  
deploy your app:

cd bin\
deploy deploy ResolverEAR.ear

you'd be able to kill this process using ctrl-c.

Getting to the heart of the matter -- java.lang.NoClassDefFoundError:  
com/framework/common/exception/FrameworkDAOException

The problem is that your lib jar files are not in the 'lib/' directory  
of your EAR. They are in the base directory of the EAR. If you move  
them into 'lib/', then your problem should be fixed.

I'm not sure how to convince Eclipse to do this for you. We've got  
some good Eclipse users/developers hanging around. Hopefully, they'll  
get you up and running.

FYI, I just repackaged your EAR with the jar files moved into lib/ and  
your app deploys without a problem...

--kevan



Mime
View raw message