geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim McConnell <tim.mcco...@gmail.com>
Subject Re: Geronimo WTP client for eclipse doesn't work as expected
Date Mon, 28 Jan 2008 16:55:26 GMT
Hi Mett, Thanks very much for trying out the Geronimo server and the Geronimo 
Eclipse plugin. The behavior you're seeing is not the normal behavior. You 
should see your application get redeployed, which it sounds like you are, and 
then see the changes in your web application and/or browser. I have a test for 
this and will double-check that it still works on 2.0.2. Meanwhile, you might 
check to ensure that you have all the required prerequisites for the 2.0.x 
plugin from here:

-----> http://geronimo.apache.org/development-tools.html

If you are at liberty to share your workspace that would help me, but if not, we 
can work around it. Thanks much....

mett wrote:
> Hi,
> 
> I am quite new at Geronimo at the moment. I have up to now been using JBoss
> as an integrated application server in my Eclipse IDE. Since I am all but
> impressed of the way that server handles memory and redeploy I am interested
> in trying out the Geronimo application server.
> 
> The status at the moment is that I have the Geronimo server 2.0.2 installed
> and working. I have a deployment plan that works and I think that the
> performance is better. 
> 
> My problem is the automatic redeploy that I can't get to work at all. When I
> alter an jsp page or a java class the WTP reacts and the server starts a
> redeploy but there isn't any change in the appearance or the files in the
> server structure.
> 
> For a change to have affect I need to remove the project with the Add and
> Remove Projects... menu option. Restart the server and the add the project
> again. This is a bit more tedious than using JBoss; to describe it mildly.
> 
> The action is exactly similar regardless of how the installation has been
> done. First I installed Geronimo by hand and the WTP from within eclipse. I
> all worked as above. After that I tried to do also the Geronimo installation
> from within eclipse. Then I got 2.0.1 with the JRE_HOME issue and upgraded
> to 2.0.2 with the above result.
> 
> I am using Maven to set up and manage my projects so the compiled files end
> up in target/classes if this is an issue.
> 
> Please guide me, I want to use Geronimo and I refuse to believe that it is
> intended to work this way.
> 
> 
> Best Regards
> 
> Mett

-- 
Thanks,
Tim McConnell

Mime
View raw message