geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bdaye <java.linebac...@gmail.com>
Subject NoSuchMethodError caused by jaxws-api
Date Tue, 29 Jan 2008 23:04:05 GMT

I am trying to get an EJB to work correctly within Geronimo.  I seem to be
having a classloader issue.  The jaxws-api-2.1 jar is in my EAR file.  I
need for my EJB to use the jaxws-api-2.1 jar and not the javax.xml.ws.*
classes found in the axis2-jaxws-api module.  The axis2-jaxws-api jar uses
older classes that do not support the
Service.createDispatch(EndpointReference, JAXBContext, Mode,
WebServiceFeature...) method.  I have tried changing the jaxws provider to
CXF and still no luck because it seems that they both hit the same
underlying jar.  In the 2.0.2 Geronimo build, you can find the jar at
{geronimo.home}/repository/org/apache/axis2/axis2-jaxws-api/1.3.  I have
tried to incorporate other configuration found in the deployment-1.2 schema
including inverse-classloading and hidden-classes (supplying filter
javax.xml.ws and javax.xml.ws.spi).  If I drop the jaxws-api-2.1 jar into
the Geronimo endorsed dir, it explodes.  If anyone has any suggestions as to
how I can get the EJB to work correctly using the jaxws-api 2.1 jar, I would
really appreciate it.

-- 
View this message in context: http://www.nabble.com/NoSuchMethodError-caused-by-jaxws-api-tp15171690s134p15171690.html
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.


Mime
View raw message