geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From gersek <ger...@gmail.com>
Subject Re: Geronimo Deployment goes forever
Date Tue, 22 Jan 2008 20:07:56 GMT

Kevan,
   THANKS for your suggestions and findings.  I was able to deploy the
application after repackaging ear lib.  For some reason eclipse is not
packaging EAR correctly.

Thanks
Sekhar

Kevan Miller wrote:
> 
> 
> 
> Your ClassNotFoundException is causing the deploy to hang. The fact  
> that the deploy is never completing is a Geronimo bug -- see 
> https://issues.apache.org/jira/browse/GERONIMO-3767
> 
> Rather than using the console, you could use the command line tool to  
> deploy your app:
> 
> cd bin\
> deploy deploy ResolverEAR.ear
> 
> you'd be able to kill this process using ctrl-c.
> 
> Getting to the heart of the matter -- java.lang.NoClassDefFoundError:  
> com/framework/common/exception/FrameworkDAOException
> 
> The problem is that your lib jar files are not in the 'lib/' directory  
> of your EAR. They are in the base directory of the EAR. If you move  
> them into 'lib/', then your problem should be fixed.
> 
> I'm not sure how to convince Eclipse to do this for you. We've got  
> some good Eclipse users/developers hanging around. Hopefully, they'll  
> get you up and running.
> 
> FYI, I just repackaged your EAR with the jar files moved into lib/ and  
> your app deploys without a problem...
> 
> --kevan
> 
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Geronimo-Deployment-goes-forever-tp14953525s134p15027184.html
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.


Mime
View raw message