geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From abpb2006 <abpb2...@yahoo.com>
Subject Re: getting ClassCastException while deploying a simple web application in geronimo 2.0
Date Mon, 14 Jan 2008 16:54:33 GMT

Not sure if i reported this earlier but yes i did get this issue sometimes
back and i put in on this forum. Then i read it was a bug and soreted out.

Now you are mentioning too. Can you pl suggest if it sorted out...thn how
get it working in my case.

I tried setting eveything, tried downloading geronimo again but no luck. I'm
sure its unique to me....otherwise many users would have put this issue.
Looks like something wrong in my enviroment or settings, plk suggest  what
might be possible soultion to this. thanks.






Jacek Laskowski wrote:
> 
> On Jan 14, 2008 9:45 AM, abpb2006 <abpb2006@yahoo.com> wrote:
> 
>> 998 Error [Deployer] Deployment failed due to
>> java.lang.ClassCastException: java.io.File
>> org.apache.geronimo.common.DeploymentException:
>> java.lang.ClassCastException: java.io.File
>>         at
>> org.apache.geronimo.deployment.Deployer.deploy(Deployer.java:385)
>>         at
>> org.apache.geronimo.deployment.Deployer.deploy(Deployer.java:126)
> 
> When I first saw it I knew I had seen it before and here it is - Need
> to fully convert to generics to avoid CCE -- a dumb example [1]. It's
> fixed in Geronimo 2.1. Can you confirm it is really the issue you've
> reported?
> 
> Jacek
> 
> [1] http://issues.apache.org/jira/browse/GERONIMO-3710
> 
> -- 
> Jacek Laskowski
> http://www.JacekLaskowski.pl
> 
> 

-- 
View this message in context: http://www.nabble.com/getting-ClassCastException-while-deploying-a-simple-web-application-in-geronimo-2.0-tp14762834s134p14805915.html
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.


Mime
View raw message