geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Garth Keesler <gar...@gdcjk.com>
Subject Re: Bank Sample App Mod to use Postgres
Date Fri, 28 Dec 2007 15:36:53 GMT
Garth Keesler wrote:
> I am new to Geronimo coming from VS2005 and C#. I have a Postgres DB 
> configured in the pool as OES and working correctly using the dbtester 
> sample app. I want to change the persistance of the Bank app from 
> Derby to Postgres and have not yet figured out the magic to make it 
> happen. The tables are correctly loaded in the OES database. Below is 
> the BankPool.xml I modified (obviously incorrectly) and I could use 
> some pointers. It mavens and installs okay but I get a "lifecycle 
> operation failed" when attempting to start in the console.
>
> Any help appreciated...
> Thx,
> Garth
>
> <?xml version="1.0" encoding="UTF-8"?>
> <!--
>    Licensed to the Apache Software Foundation (ASF) under one
>    or more contributor license agreements.  See the NOTICE file
>    distributed with this work for additional information
>    regarding copyright ownership.  The ASF licenses this file
>    to you under the Apache License, Version 2.0 (the
>    "License"); you may not use this file except in compliance
>    with the License.  You may obtain a copy of the License at
>      http://www.apache.org/licenses/LICENSE-2.0
>      Unless required by applicable law or agreed to in writing,
>    software distributed under the License is distributed on an
>    "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
>    KIND, either express or implied.  See the License for the
>    specific language governing permissions and limitations
>    under the License.
> -->
> <connector xmlns="http://geronimo.apache.org/xml/ns/j2ee/connector-1.1">
>    <dep:environment 
> xmlns:dep="http://geronimo.apache.org/xml/ns/deployment-1.1">
>        <dep:moduleId>
>            <dep:groupId>console.dbpool</dep:groupId>
>            <dep:artifactId>OES</dep:artifactId>
>            <dep:version>1.0</dep:version>
>            <dep:type>rar</dep:type>
>        </dep:moduleId>
>        <dep:dependencies>
>            <dep:dependency>
>                <dep:groupId>org.apache.geronimo.configs</dep:groupId>
>                <dep:artifactId>system-database</dep:artifactId>
>                <dep:type>car</dep:type>
>            </dep:dependency>
>        </dep:dependencies>
>    </dep:environment>
>    <resourceadapter>
>        <outbound-resourceadapter>
>            <connection-definition>
>                
> <connectionfactory-interface>javax.sql.DataSource</connectionfactory-interface>

>
>                <connectiondefinition-instance>
>                    <name>BankPool</name>
>                    <config-property-setting 
> name="Driver">org.postgresql.Driver</config-property-setting>
>                    <config-property-setting 
> name="UserName">garthk</config-property-setting>
>                    <config-property-setting 
> name="ConnectionURL">jdbc:postgresql://pgsrv/oesdb</config-property-setting>

>
>                    <connectionmanager>
>                        <local-transaction/>
>                        <single-pool>
>                            <max-size>10</max-size>
>                            <min-size>0</min-size>
>                            <match-one/>
>                        </single-pool>
>                    </connectionmanager>
>                </connectiondefinition-instance>
>            </connection-definition>
>        </outbound-resourceadapter>
>    </resourceadapter>
> </connector>
>
> .
>
Making some progress with other XML files, particularly persistence.xml.

Still working the prob.

Pointers welcome,
Garth

Mime
View raw message