geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Viet Nguyen" <vhng...@gmail.com>
Subject Re: Newbee -- unable to build the sample application
Date Thu, 01 Nov 2007 19:15:19 GMT
Matt,

For the samples, you probably do not want to change the POMs. You
probably changed the pom's parent's module ids so it couldn't find it.
This was primarily why I asked if you have tried it out on other
samples because I was afraid that you did not have a clean copy of the
sample itself.

Regards,
Viet Nguyen

On Nov 1, 2007 1:43 PM, Matthew Simmons <matthewbsimmons@gmail.com> wrote:
> Gentlemen,
>
> That did it.  Just for my own education, why did I need to update via
> Subversion?  I have talked to people who ran it without doing so.  Did I
> screw up the POM file or something (that was the only thing updated)?
>
> Thanks Jarek and Viet.
> Matt
>
>
>
> On 11/1/07, Jarek Gawor <jgawor@gmail.com> wrote:
> > Do svn up and try again.
> >
> > Jarek
> >
> > On 11/1/07, Matthew Simmons <matthewbsimmons@gmail.com> wrote:
> > > Viet,
> > >
> > > Thanks for the response.
> > >
> > > Yes, I've tried to run 'mvn install' with the other samples and I get
> the
> > > same outcome.  I am posting the stack trace below.
> > >
> > > Matt
> > >
> > > C:\Geronimo\Samples\calculator\jaxws-calculator-war>mvn
> > > install
> > > [INFO] Scanning for projects...
> > > [INFO]
> > > ------------------------------------------------------------------------
> > > [ERROR] FATAL ERROR
> > > [INFO]
> > > ------------------------------------------------------------------------
> > > [INFO] Error building POM (may not be this project's POM).
> > >
> > >
> > > Project ID: null:jaxws-calculator:pom:null
> > >
> > > Reason: Cannot find parent:
> > > org.apache.geronimo.samples:samples for project: nul
> > > l:jaxws-calculator:pom:null for project null:jaxws-calculator:pom:null
> > >
> > >
> > > [INFO]
> > > ------------------------------------------------------------------------
> > > [INFO] Trace
> > > org.apache.maven.reactor.MavenExecutionException: Cannot
> > > find parent: org.apache
> > > .geronimo.samples:samples for project: null:jaxws-calculator:pom:null
> for
> > > projec
> > > t null:jaxws-calculator:pom:null
> > >         at
> > > org.apache.maven.DefaultMaven.getProjects(DefaultMaven.java:378)
> > >         at
> > > org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:290)
> > >         at org.apache.maven.DefaultMaven.execute
> > > (DefaultMaven.java:125)
> > >         at
> > > org.apache.maven.cli.MavenCli.main(MavenCli.java:280)
> > >         at
> > > sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> > >         at sun.reflect.NativeMethodAccessorImpl.invoke
> > > (Unknown Source)
> > >         at
> > > sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown
> > > Source)
> > >         at java.lang.reflect.Method.invoke(Unknown Source)
> > >         at
> > > org.codehaus.classworlds.Launcher.launchEnhanced (Launcher.java
> > > :315)
> > >         at
> > > org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
> > >         at
> > > org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
> > >
> > >         at org.codehaus.classworlds.Launcher.main(
> > > Launcher.java:375)
> > > Caused by:
> > > org.apache.maven.project.ProjectBuildingException: Cannot
> > > find parent
> > > : org.apache.geronimo.samples:samples for project:
> > > null:jaxws-calculator:pom:nul
> > > l for project null:jaxws-calculator:pom:null
> > >         at
> > > org.apache.maven.project.DefaultMavenProjectBuilder.assembleLineage(D
> > > efaultMavenProjectBuilder.java :1261)
> > >         at
> > > org.apache.maven.project.DefaultMavenProjectBuilder.assembleLineage(D
> > > efaultMavenProjectBuilder.java :1278)
> > >         at
> > > org.apache.maven.project.DefaultMavenProjectBuilder.buildInternal (Def
> > > aultMavenProjectBuilder.java:747)
> > >         at
> > > org.apache.maven.project.DefaultMavenProjectBuilder.buildFromSourceFi
> > > leInternal( DefaultMavenProjectBuilder.java:479)
> > >         at
> > > org.apache.maven.project.DefaultMavenProjectBuilder.build(DefaultMave
> > > nProjectBuilder.java:200)
> > >         at
> > > org.apache.maven.DefaultMaven.getProject(DefaultMaven.java
> > > :553)
> > >         at
> > > org.apache.maven.DefaultMaven.collectProjects(DefaultMaven.java:467)
> > >         at
> > > org.apache.maven.DefaultMaven.getProjects(DefaultMaven.java:364)
> > >         ... 11 more
> > > Caused by:
> > > org.apache.maven.project.ProjectBuildingException : POM
> > > 'org.apache.ge
> > > ronimo.samples:samples' not found in repository: Unable to download the
> > > artifact
> > >  from any repository
> > >
> > >   org.apache.geronimo.samples:samples:pom:2.1-SNAPSHOT
> > >
> > > from the specified remote repositories:
> > >   central (http://repo1.maven.org/maven2 )
> > >  for project org.apache.geronimo.samples:samples
> > >         at
> > > org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepo
> > > sitory(DefaultMavenProjectBuilder.java:573)
> > >         at
> > > org.apache.maven.project.DefaultMavenProjectBuilder.assembleLineage(D
> > > efaultMavenProjectBuilder.java:1257)
> > >         ... 18 more
> > > Caused by:
> > > org.apache.maven.artifact.resolver.ArtifactNotFoundException
> > > : Unable
> > > to download the artifact from any repository
> > >
> > >   org.apache.geronimo.samples:samples:pom:2.1-SNAPSHOT
> > >
> > > from the specified remote repositories:
> > >   central ( http://repo1.maven.org/maven2 )
> > >
> > >         at
> > > org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(De
> > > faultArtifactResolver.java:197)
> > >         at
> > > org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve (De
> > > faultArtifactResolver.java :73)
> > >         at
> > > org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepo
> > > sitory(DefaultMavenProjectBuilder.java:526)
> > >         ... 19 more
> > > Caused by:
> > > org.apache.maven.wagon.ResourceDoesNotExistException :
> > > Unable to downl
> > > oad the artifact from any repository
> > >         at
> > > org.apache.maven.artifact.manager.DefaultWagonManager.getArtifact (Def
> > > aultWagonManager.java:324)
> > >         at
> > > org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve
> > > (De
> > > faultArtifactResolver.java:185)
> > >         ... 21 more
> > > [INFO]
> > > ------------------------------------------------------------------------
> > > [INFO] Total time: < 1 second
> > > [INFO] Finished at: Thu Nov 01 07:02:01 EDT 2007
> > > [INFO] Final Memory: 1M/4M
> > > [INFO]
> > > ------------------------------------------------------------------------
> > >
> > > C:\Geronimo\Samples\calculator\jaxws-calculator-war>
> > >
> > >
> > > On 10/31/07, Viet Nguyen < vhnguy2@gmail.com> wrote:
> > > > Have you tried to run 'mvn install' with other samples? Also, if you
> > > > could post the full stack trace, it will be helpful too.
> > > >
> > > > Regards,
> > > > Viet
> > > >
> > > > On Oct 31, 2007 11:59 AM, Matthew Simmons < matthewbsimmons@gmail.com>
> > > wrote:
> > > > > I'm new to the Geronimo/Apache world, so please forgive my
> ignorance.
> > > > >
> > > > > I'm having trouble building the sample application on my computer.
> I
> > > have
> > > > > Geronimo loaded successfully, according to the command window.  I
> also
> > > have
> > > > > Subversion correctly loaded and my path properly updated to manage
> > > requests
> > > > > -- I can verify that with 'svn help' in the command prompt.
> Finally, I
> > > have
> > > > > successfully loaded Maven and properly updated the path as verified
> by
> > > 'mvn
> > > > > --version' at the command prompt.
> > > > >
> > > > > I have successfully checked out the JAX-WS example with Subversion
> and
> > > all
> > > > > of the files appear to have loaded on my machine successfully.  When
> I
> > > > > navigate to the calculator/jaxws-calculator-war directory and
> activate
> > > Maven
> > > > > with 'mvn install' (as indicated in the sample write up), the build
> > > fails
> > > > > witrh 'FATAL ERROR' and 'Error building POM (may not be the
> project's
> > > POM)'.
> > > > > I have talked through this with people that can successfully build
> with
> > > the
> > > > > same files following the same steps.
> > > > >
> > > > > My correction steps have been:
> > > > > 1.  uninstall/reinstall everything
> > > > > 2.  ensure no firewalls are active
> > > > > 3.  rebuilt countless times
> > > > >
> > > > > Does anyone have any advice as to what I'm doing wrong?
> > > > >
> > > > > Thanks for your time.
> > > > > Matt
> > > > >
> > > > > Maven 2.0.7
> > > > > Geronimo 2.0
> > > > > Java 1.6.0_03
> > > > > Windows XP
> > > > >
> > > >
> > >
> > >
> >
>
>

Mime
View raw message