geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jay D. McHugh" <...@jnwd.net>
Subject Re: JSP version
Date Mon, 19 Nov 2007 22:13:59 GMT
John,

That 'Apache-Coyote/1.1' header does not actually have anything to do
with the versions of the spec that are supported.  Geronimo 2.x supports
Servlet 2.5 and JSP 2.1 (as Joe already mentioned) and I believe that he
is also correct that they are fully backward compatible.

Do you specifically need less that 2.5/2.1?  Or were you more concerned
that you have at least 2.4/1.3?

Jay

John Richard Moser wrote:
> nmap is telling me the JSP engine in use is 1.1 (I know Jetty at least
> comes with multiple engine JARs).  Server header is "Apache-Coyote/1.1"
> so I don't know.
> 
> 8080/tcp  open  http    Apache Tomcat/Coyote JSP engine 1.1
> 
> 
> Joe Bohn wrote:
>> The latest Geronimo released is 2.0.2 and it includes support for
>> Servlet 2.5 & JSP 2.1.   Geronimo 1.1.1 was Servlet 2.4 and JSP 2.0. 
>> I suspect either should be downward compatible with Servlet 2.4 & JSP
>> 1.3.
>>
>> Joe
>>
>>
>> John Richard Moser wrote:
>>> nmap claims Tomcat/Catalina JSP 1.1 for the latest Geronimo, but I
>>> need version 1.3 (Servelet 2.4, JSP 1.3) for my application.  Is
>>> there somewhere to check the config and to change the JSP version?
>>
> 



Mime
View raw message