geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jacek Laskowski" <ja...@laskowski.net.pl>
Subject Re: EntityExistsException: Attempt to persist detached object
Date Mon, 26 Nov 2007 09:12:59 GMT
On Nov 26, 2007 9:47 AM, maho77 <m.hoffmann@mvolution.de> wrote:

> I tried it with an unitialized id field and ran into another exception:
>
> 09:40:29,126 WARN  [Transaction] Unexpected exception from beforeCompletion;
> transaction will roll back
> <openjpa-1.0.0-r420667:568756 nonfatal general error>
> org.apache.openjpa.persistence.PersistenceException: null
>         at
> org.apache.openjpa.jdbc.kernel.AbstractJDBCSeq.getConnection(AbstractJDBCSeq.java:162)
>         at
> org.apache.openjpa.jdbc.kernel.TableJDBCSeq.allocateSequence(TableJDBCSeq.java:341)

Hi,

Could you send us the openjpa logs - it should be in
var/log/geronimo.log? I assume they're generated according to the
property in persistence.xml:

<property name="openjpa.Log" value="DefaultLevel=TRACE,SQL=TRACE" />

I wonder why you do the following in the stand-alone client code:

 MTIGroup g1 = new MTIGroup();
 g1.setId(2);
 g1.setName("testGroup");

Note the setId() call.

The null from org.apache.openjpa.jdbc.kernel.AbstractJDBCSeq.getConnection(AbstractJDBCSeq.java:162)
call suggests that there might be issues with geronimo plan file of
the application. You've got
<jta-data-source>xxxDataSouurce</jta-data-source> in persistence.xml
file - there's 'u' doubled. Is that correct? Send us the geronimo plan
you're using with the application. Is the data source one of the
default data sources of Geronimo?

I have never worked with mysql and TableGenerator for jpa-based
application in Geronimo so I'm asking these question to avoid dealing
with the setup *if* the issue is simpler to fix without it.

Jacek

-- 
Jacek Laskowski
http://www.JacekLaskowski.pl

Mime
View raw message