geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jacek Laskowski" <ja...@laskowski.net.pl>
Subject Re: deployment file help
Date Mon, 19 Nov 2007 15:06:39 GMT
On Nov 19, 2007 3:58 PM, John Richard Moser <nigelenki@comcast.net> wrote:

> I currently have something akin to... (sorry for all the foo; I'm not
> sure how much internal app info my company wants me posting around the net)
>
> <?xml version="1.0" encoding="UTF-8"?>
>   <web-app xmlns="http://geronimo.apache.org/xml/ns/j2ee/web-1.1">
>    <environment xmlns="http://geronimo.apache.org/xml/ns/deployment-1.1">
>     <moduleId>
>      <groupId>foo</groupId>
>      <artifactId>Foo</artifactId>
>      <version>2.2</version>
>      <type>war</type>
>     </moduleId>
>    </environment>
>    <context-root>/foo</context-root>
>   </web-app>
>
> All the 1.1 stuff is 'cause 2.0 doesn't have great documentation :s

The file looks fine to me. What's the issue then? Did you deploy the
webapp? What were the error messages if any?

> This is equivalent to the inclusion of the following element in the web
> application deployment descriptor (/WEB-INF/web.xml):
>
> <context-param>
>    <param-name>companyName</param-name>
>    <param-value>My Company, Incorporated</param-value>
> </context-param>
>
> but does not require modification of the deployment descriptor to
> customize this value.

It's your webapp, isn't it? I'm pretty sure you can mimic something
akin to it in geronimo-web.xml, but let's leave it until we really
need it. Deploy the webapp and send the error messages you encounter.

I assume you're working with geronimo 2.0.2 at the very least.

Jacek

-- 
Jacek Laskowski
http://www.JacekLaskowski.pl

Mime
View raw message