geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jacek Laskowski" <>
Subject Re: deploying a new app with change in package name - NoClassDefFoundError
Date Sat, 10 Nov 2007 10:43:30 GMT
On Nov 9, 2007 9:08 PM, MShah <> wrote:

> I am deploying a new web application and I had to change the package name for
> the class files and then redeploy them.  Since I changed the package name
> the jsp pages are unable to find the class files.  The application compiles
> perfectly and there is no problem then with the JSP.  When loading the app I
> get this error:
> HTTP Status 500 -

How do you deploy the new application? One way to fix it with a
minimal effort would be to undeploy the previous version of the
application and deploy the latest one, i.e. not rely on the hot
deployment feature.

Use a web console to undeploy/deploy the web app or try it out on the
command line:

jlaskowski@dev /cygdrive/c/geronimo
$ ./bin/ -u system -p manager undeploy

jlaskowski@dev /cygdrive/c/geronimo
$ ./bin/ -u system -p manager deploy the.war the-war-plan.xml

where the-war-plan contains:

    <web-app xmlns="">
      <environment xmlns="">

You may want to remove the directory - repository/my/group/id from the
Geronimo's repository, too.

You didn't mention what Geronimo version you're using. I can only
guess you're using Eclipse. If so, what plugin version it runs with?
Not much about your environment so the answer is a bit wacky.


Jacek Laskowski

View raw message