geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jacek Laskowski" <ja...@laskowski.net.pl>
Subject Re: Lifecycle Operation Failed problem - solved
Date Wed, 07 Nov 2007 19:06:56 GMT
On 11/7/07, Jacek Laskowski <jacek@laskowski.net.pl> wrote:

> Yeah, tried it out already. I thought that hidding xstream classes
> might've helped, but it didn't. Still working on it.

Solved it! Hurrray.

jlaskowski@dev /cygdrive/c/geronimo
$ ./bin/deploy.sh -u system -p manager deploy hudson.war
hudson-geronimo-plan.xml
Using GERONIMO_BASE:   c:\geronimo
Using GERONIMO_HOME:   c:\geronimo
Using GERONIMO_TMPDIR: c:\geronimo\var\temp
Using JRE_HOME:        c:\apps\java5\jre
    Deployed hudson/hudson/1.153/war @ /hudson

and on the console:

hudson home directory: C:\Documents and Settings\jlaskowski\.hudson
2007-11-07 19:57:46 hudson.TcpSlaveAgentListener <init>
INFO: JNLP slave agent listener started on TCP port 2446
2007-11-07 19:57:46 hudson.model.Hudson load
INFO: Took 31 ms to load

The issue was with the very old xstream jar in lib directory. Geronimo
uses 1.1.3, but when I upgraded (copied over) to 1.2.2 it deployed
fine. It looks like

    <hidden-classes>
      <filter>com.thoughtworks.xstream</filter>
    </hidden-classes>

doesn't work for jars in lib.

I'm going to see if Geronimo builds with xstream 1.2.2 and check the change in.

One more thing, it worked fine with today's Geronimo build as well as 2.0.2.

The plan - hudson-geronimo-plan.xml is as follows:

<?xml version="1.0" encoding="UTF-8"?>
<web-app xmlns="http://geronimo.apache.org/xml/ns/j2ee/web-2.0">
  <environment xmlns="http://geronimo.apache.org/xml/ns/deployment-1.2">
    <moduleId>
      <groupId>hudson</groupId>
      <artifactId>hudson</artifactId>
      <version>1.153</version>
      <type>war</type>
    </moduleId>
    <dependencies>
      <dependency>
        <groupId>org.apache.geronimo.configs</groupId>
        <artifactId>j2ee-security</artifactId>
        <type>car</type>
      </dependency>
    </dependencies>
    <hidden-classes>
      <filter>com.thoughtworks.xstream</filter>
    </hidden-classes>
    <non-overridable-classes />
    <inverse-classloading />
  </environment>

  <context-root>/hudson</context-root>

  <security-realm-name>HudsonRealm</security-realm-name>
  <security>
    <default-principal realm-name="HudsonRealm">
      <principal name="anonymous"
class="org.apache.geronimo.security.realm.providers.GeronimoUserPrincipal"
/>
    </default-principal>
    <role-mappings>
      <role role-name="admin">
        <realm realm-name="HudsonRealm">
          <principal name="AdminGroup"
class="org.apache.geronimo.security.realm.providers.GeronimoGroupPrincipal"
/>
        </realm>
        <principal name="system"
class="org.apache.geronimo.security.realm.providers.GeronimoUserPrincipal"
/>
      </role>
    </role-mappings>
  </security>

</web-app>

Jacek

-- 
Jacek Laskowski
http://www.JacekLaskowski.pl

Mime
View raw message