geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jacek Laskowski" <ja...@laskowski.net.pl>
Subject Re: problems when deploy ejb in eclipse
Date Tue, 06 Nov 2007 23:34:02 GMT
On 11/6/07, beyondjustin@gmail.com <beyondjustin@gmail.com> wrote:

> Distribution of configuration failed.  See log for details.
>   unknown protocol: localhost
>   java.net.MalformedURLException: unknown protocol: localhost
>   at java.net.URL.<init>(Unknown Source)
>   at java.net.URL.<init>(Unknown Source)
>   at java.net.URL.<init>(Unknown Source)
>   at org.apache.geronimo.deployment.plugin.local.AbstractDeployCommand.getRemoteDeployUploadURL(AbstractDeployCommand.java:149)
...
> Eclipse-3.3.0
>
> Web Standard Tools-Version: 2.0.1
>
> geronimo-jetty6-jee5-2.0.1
>
> linux-Red had Enterprise 7.0(server installed on it)
>
> xDoclet-1.2.3

Hi,

Not that it sorts out the issue, but could you upgrade your
environment to Eclipse 3.3.1, Geronimo Eclipse Plugin 2.0.0 and
Geronimo 2.0.2? I'm not certain what exactly issues were faced, but
WTP in Eclise 3.3 made us some troubles that were fixed with the
recent versions. You may find the ant script (see Prerequisites on
Welcome to Apache Geronimo Development Tools Subproject [1]) very
handy.

I'm working on a article about Geronimo, Eclipse, M2Eclipse and Spring
Framework so can't help much until I've finished it (almost done), but
as you see I'm nearly where I should be to help you out ;-) If only
you could upgrade the env...

Jacek

[1] http://geronimo.apache.org/development-tools.html

-- 
Jacek Laskowski
http://www.JacekLaskowski.pl

Mime
View raw message