geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From beyondjusitn <>
Subject Re: 5-minute Tutorial on Enterprise Application Development with Eclipse and Geronimo (was Re: problems when deploy ejb in eclipse)
Date Wed, 21 Nov 2007 16:13:55 GMT

Thank you Jacek. Probably I will give up Eclipse. And turn to NetBeans
Can I discuss something about EJB with you. After trying out
Eclipse+Geronimo+EJB, I am kinda realizing that maybe this combination is
not a perfect combination. So, what is the perfect combination to develop
EJB projects? Could you give me come advice? Would NetBean+Geronimo+EJB the
best choice?
Thanks again.

Jacek Laskowski wrote:
> On Nov 21, 2007 9:57 AM, beyondjusitn <> wrote:
>> But I have another problem after following your tutorial. After the first
>> time I created all the projects in your tutorial, if I close eclipse,
>> then
>> reopen eclipse, there will be an error in SampleWAR project. I find out
>> that
>> it is a problem of J2EE Module Dependency. So, again I right click on
>> SampleWAR, choose' property', then 'J2EE Module Dependencies', I found
>> that
>> it is different from the first time I come here. If I choose SampleEJB,
>> the
>> error is fixed, however, I met deploy problems. I have no choice but to
>> redo
>> all the three projects to get them running. Why?
> Hi,
> I dunno. I'm a typical Eclipse user so although I run across the issue
> too I didn't pay much attention to it. Just accepted that it could
> work this way. Honestly, I'm not really interested in fixing Eclipse
> bugs (as there're better things to do) so while annoying I can live
> with it (I hope that one day you'll have a choice and try out netbeans
> with geronimo plugin - it won't happen overnight, but I'm sure it
> will). Please rise an issue for it in geronimo-eclipse-plugin jira so
> it won't be overlooked.
>> Another problem is that my Eclipse kept errepting, saying something like
>> memory leaked. Is that because the Eclipse I'm using? I'm using Eclipse
>> 3.3.1, Eclipse Data Tools Platform Enablement Version:
>> and
>> Eclipse Modeling Framework (EMF) Source Version: 2.3.1.v200709252135.
> It appears like Eclipse misbehaviour. Perhaps it could also mean that
> the plugin needs more attention. I'd rise an issue in
> geronimo-eclipse-plugin jira and wait for a fix.
> Jacek
> -- 
> Jacek Laskowski

Best Wishes!
Justin Tsao
View this message in context:
Sent from the Apache Geronimo - Users mailing list archive at

View raw message