geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ak345 <ak334...@hotmail.com>
Subject 1 required artifact missing
Date Sat, 03 Nov 2007 22:01:36 GMT

Am trying to build ''Web application security sample''
(http://cwiki.apache.org/GMOxDOC20/web-application-security-sample.html). 
After I typed 'mvn install site' under timereport directory, an error came
out. I paste the result below.

 
[INFO]
------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO]
------------------------------------------------------------------------
[INFO] Error during page generation

Embedded error: Error rendering Maven report: Missing:
----------
1) org.apache.geronimo.samples:timereport-war:war:2.0-SNAPSHOT

  Try downloading the file manually from the project website.

  Then, install it using the command:
      mvn install:install-file -DgroupId=org.apache.geronimo.samples
-DartifactI
d=timereport-war \
          -Dversion=2.0-SNAPSHOT -Dpackaging=war -Dfile=/path/to/file
Alternatively, if you host your own repository you can deploy the file
there:
    mvn deploy:deploy-file -DgroupId=org.apache.geronimo.samples
-DartifactId=ti
mereport-war \
          -Dversion=2.0-SNAPSHOT -Dpackaging=war -Dfile=/path/to/file \
           -Durl=[url] -DrepositoryId=[id]

  Path to dependency:
        1) org.apache.geronimo.samples:timereport-ear:ear:2.0-SNAPSHOT
        2) org.apache.geronimo.samples:timereport-war:war:2.0-SNAPSHOT

----------
1 required artifact is missing.

for artifact:
  org.apache.geronimo.samples:timereport-ear:ear:2.0-SNAPSHOT

from the specified remote repositories:
  apache.snapshots (http://people.apache.org/repo/m2-snapshot-repository),
  apache-incubator
(http://people.apache.org/repo/m2-incubating-repository/),
  codehaus (http://repository.codehaus.org),
  codehaus-snapshots (http://snapshots.repository.codehaus.org),
  apache-snapshots (http://people.apache.org/repo/m2-snapshot-repository),
  central (http://repo1.maven.org/maven2)

[INFO]
------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO]
------------------------------------------------------------------------
[INFO] Total time: 8 seconds
[INFO] Finished at: Sat Nov 03 17:26:31 EDT 2007
[INFO] Final Memory: 18M/32M
[INFO]
------------------------------------------------------------------------

how to solve this problem?

Am a beginner, many thanks.

Moussa

-- 
View this message in context: http://www.nabble.com/1-required-artifact-missing-tf4744574s134.html#a13567452
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.


Mime
View raw message