geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jay D. McHugh" <...@joyfulnoisewebdesign.com>
Subject Re: classes in a web application cannot be found
Date Tue, 16 Oct 2007 17:49:00 GMT
It kind of looks like the problem is that either the 'request' or 
'response' variables is null rather than Geronimo being unable to find 
the 'P2k6AppCtl' class.

Can you check to make sure that those two variable are not null?

Jay

David Jencks wrote:
>
> On Oct 16, 2007, at 10:28 AM, MShah wrote:
>
>>
>> The version of Geronimo is 2.0.1.  I am deploying it as a war file.
>>
>> The war file gets deployed to the following location:
>> repository\default\p2k6App\1192229987483\p2k6App-1192229987483.war
>>
>> where in I have the META-INF, WEB-INF and jsp files.  In the WEB-INF
>> directory I have to folders called classes and lib.  In the lib 
>> directory I
>> have all the jar files.  In the classes directory I have the class 
>> files in
>> the appropriate package structured folders.  At the level of the classes
>> directory I have the web.xml file as well.
>>
>> The stack trace is as follows:
>>
>> java.lang.NullPointerException
>> which is right when I am instantiating the class like P2k6AppCtl a = new
>> P2k6AppCtl(request, response);
>
> I don't quite understand how this code would produce a NPE rather than 
> a ClassNotFoundException or NoClassDefFoundError.  Could you explain?
>
> thanks
> david jencks
>
>>
>> Any input on resolving this will be much appreciated.
>>
>> Thanks,
>> Manisha
>>
>>
>>
>> Jay D. McHugh wrote:
>>>
>>> A couple of questions:
>>>
>>> 1) What version of Geronimo are you using?
>>> 2) Are you deploying your application as a WAR or as an EAR?
>>> 3) What is the file layout of your deployment file (the WAR or EAR)?
>>> 4) Do you have a stack trace?
>>>
>>> Jay
>>>
>>> MShah wrote:
>>>> I am deploying a we application using myeclipse, the application gets
>>>> deployed perfectly, however the classes in the WEB-INF/classes 
>>>> directory
>>>> cannot be found.  The jars in the lib drectory are being loaded 
>>>> correctly
>>>> as
>>>> I am referencing a static variable in the jars and it prints out
>>>> perfectly,
>>>> but when one of the class is being instantiated in the jsp page I 
>>>> get a
>>>> nullpointer exception.
>>>>
>>>> Any inputs on resolving this will be much appreciated.
>>>>
>>>> Thanks and regards,
>>>> M. Shah
>>>>
>>>
>>>
>>
>> --View this message in context: 
>> http://www.nabble.com/classes-in-a-web-application-cannot-be-found-tf4635417s134.html#a13238423

>>
>> Sent from the Apache Geronimo - Users mailing list archive at 
>> Nabble.com.
>>
>
>
>
>

Mime
View raw message