geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jacek Laskowski" <ja...@laskowski.net.pl>
Subject Re: error whilst deploying entity bean
Date Tue, 30 Oct 2007 12:26:26 GMT
On 10/29/07, Neo Anderson <javadeveloper999@yahoo.co.uk> wrote:

> geronimo-ejb_3.0_spec-1.0.jar
> tranql-connector-ra-1.3.rar
> geronimo-jpa_3.0_spec-1.1.jar
> geronimo-annotation_1.0_spec-1.1.jar
> tranql-connector-1.3.jar

Why do you need these? Create META-INF/geronimo-application.xml and
add dependencies there. They're available in repository so no need to
duplicate.

> net/sf/sample/PublicationLocal.class

Hmm, it's here, so is this a classloading issue? Missing dependencies?

> WEB-INF/lib/geronimo-ejb_3.0_spec-1.0.jar
> WEB-INF/lib/geronimo-jpa_3.0_spec-1.1.jar
> WEB-INF/lib/geronimo-annotation_1.0_spec-1.1.jar

Remove these and add as dependencies in geronimo-web.xml

Did you follow the steps as described in the documentation - The Phone
Book Bean Example?

Jacek

-- 
Jacek Laskowski
http://www.JacekLaskowski.pl

Mime
View raw message