geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ed Hillmann" <ed.hillm...@gmail.com>
Subject Fwd: ra.xml parse error when deploying JCA adapter
Date Mon, 17 Sep 2007 04:22:44 GMT
I tried sending this with the rar as an attachment, but I was told it was spam.

But the RAR being used contains the ActivationSpec that cannot be
found.... I promise.  I'll try emailing you directly, David, with the
JAR. :)

Thanks,
Ed

---------- Forwarded message ----------
From: Ed Hillmann <ed.hillmann@gmail.com>
Date: Sep 17, 2007 2:19 PM
Subject: Re: ra.xml parse error when deploying JCA adapter
To: user@geronimo.apache.org


> It's nice to hear something good about that since I hated writing it
> and haven't been maintaining it very well :-)  Maybe now I'll find
> some more motivation :-)

Please, write more. :)  It's too often that when there's an error, an
application server just knocks you back.  It's very nice to see
something make an attempt of seeing if there's anything it can do to
move you along.

>
> >
> >
> > Am I missing something else in the geronimo-ra.xml file?  It seems to
> > know about the correct ActivationSpec class.  Just not that it needs
> > to use the RAR file being deployed?
>
> I'd guess that you don't have the dependencies set up as well as you
> think :-)
>
> Can you verify which jar this activation spec is actually in and show
> the structure of the rar and the environment section of the plan?
>

I'll attach the RAR and deployment files.  I'm certain that the
ActivationSpec is contained within the RAR file.  The plan file is

<connector xmlns="http://geronimo.apache.org/xml/ns/j2ee/connector-1.2">
  <dep:environment xmlns:dep="http://geronimo.apache.org/xml/ns/deployment-1.2">
    <dep:moduleId>
      <dep:groupId>com.intecbilling.singleview</dep:groupId>
      <dep:artifactId>svConnector</dep:artifactId>
      <dep:version>1.0</dep:version>
      <dep:type>rar</dep:type>
    </dep:moduleId>
    <dep:dependencies>
      <dep:dependency>
        <dep:groupId>com.intecbilling.singleview</dep:groupId>
        <dep:artifactId>enterprise-java-interface</dep:artifactId>
        <dep:version>6.01.05.01</dep:version>
        <dep:type>jar</dep:type>
      </dep:dependency>
    </dep:dependencies>
    <dep:hidden-classes/>
    <dep:non-overridable-classes/>
  </dep:environment>
  <resourceadapter>
    <resourceadapter-instance>
      <resourceadapter-name>Singl.eView Inbound Resource
Adapter</resourceadapter-name>
      <workmanager>
        <gbean-link>DefaultWorkManager</gbean-link>
      </workmanager>
    </resourceadapter-instance>
    <outbound-resourceadapter>
      <connection-definition>
        <connectionfactory-interface>javax.resource.cci.ConnectionFactory</connectionfactory-interface>
        <connectiondefinition-instance>
          <name>SingleViewAdapter</name>
          <connectionmanager>
            <xa-transaction>
              <transaction-caching/>
            </xa-transaction>
            <single-pool>
              <max-size>10</max-size>
              <blocking-timeout-milliseconds>5000</blocking-timeout-milliseconds>
              <match-one/>
            </single-pool>
          </connectionmanager>
        </connectiondefinition-instance>
      </connection-definition>
    </outbound-resourceadapter>
  </resourceadapter>
</connector>

Do I have to make it dependent on itself?  The only dependency I have
included in the plan is an external jar file on which the Adapter
depends in order to communicate with the back end.  But it doesn't
contain any JCA-implementations.

Thanks again,
Ed

Mime
View raw message