geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From PeterAU2 <i...@plusplus.com.au>
Subject Re: Deployment plan required
Date Fri, 28 Sep 2007 06:58:58 GMT

Thanks sol. I was trying G1.0 as I was getting further with my application
than with 2.0.
I've since given up on 1.0, and are focussing on getting 2.0.1 working.
Anything you could contribute to this thread:
http://www.nabble.com/forum/ViewPost.jtp?post=12932131&framed=y&skin=134
would be appreciated.
Peter


solprovider-2 wrote:
> 
> Hi Peter,
> 
> You are attempting to deploy a JAR.  Geronimo requires a WAR or an
> EAR.  A WAR must include WEB-INF/web.xml and have the different
> extension.  You can create a WAR with any zip program, Java's jar
> command, Eclipse, and other programs.
> 
> My experience was with Geronimo 2.0 (or maybe 1.2.)  I never created a
> deployment plan or any files specifically for Geronimo.
> 
> Why are you starting with an obsolete version?  I will contribute
> towards getting you a more recent release if you need help.
> 
> solprovider
> 
> 
> On 9/27/07, PeterAU2 <info@plusplus.com.au> wrote:
>>
>> Hi. Please forgive my second newbie question!
>>
>> I'm also trying to get the Geronimo Hello world sample to work, from
>> http://cwiki.apache.org/GMOxDOC11/deployment-plans-level-1.html
>> Heading: Deploying JAR containing Simple EJB application
>>
>> I'm running Geronimo 1.0, but am thinking this example from 1.1 should
>> work?
>>
>> When I attempt to deploy using the console, if I just enter the Archive
>> file
>> helloworld-ejbs.jar and no Plan I get the error:
>> 'Currently a Geronimo deployment plan is required for an EJB module. 
>> Please
>> provide a plan as a deployer argument or packaged in the EJB JAR at
>> META-INF/openejb-jar.xml'
>> If I include the file META-INF\openejb-jar.xml (listed at bottom) then I
>> get
>> the same error.
>>
>> Please help.
>>
>> I'll update the wiki once I get this to work!
>>
>> Thanks again
>> Peter
>>
>> <openejb-jar xmlns="http://www.openejb.org/xml/ns/openejb-jar-2.1">
>>   <dep:environment
>> xmlns:dep="http://geronimo.apache.org/xml/ns/deployment-1.1">
>>     <dep:moduleId>
>>       <dep:groupId>org.geronimo.</dep:groupId>
>>       <dep:artifactId>ejbsample</dep:artifactId>
>>       <dep:version>1.0</dep:version>
>>       <dep:type>car</dep:type>
>>     </dep:moduleId>
>>     <dep:dependencies/>
>>     <dep:hidden-classes/>
>>     <dep:non-overridable-classes/>
>>   </dep:environment>
>>   <enterprise-beans>
>>     <session>
>>       <ejb-name>HelloBean</ejb-name>
>>       <jndi-name>org.geronimo.ejbsample.HomeBean</jndi-name>
>>     </session>
>>   </enterprise-beans>
>> </openejb-jar>
>> --
>> View this message in context:
>> http://www.nabble.com/Deployment-plan-required-tf4531791s134.html#a12932664
>> Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.
> 
> 

-- 
View this message in context: http://www.nabble.com/Deployment-plan-required-tf4531791s134.html#a12935627
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.


Mime
View raw message