geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carver <carver...@gmail.com>
Subject Re: Problem with defining custom Valve in config.xml
Date Thu, 20 Sep 2007 16:56:30 GMT

Oh, my mistake! It should be "org.company". Thanks for your remind.


Janko Heilgeist-2 wrote:
> 
> Hi,
> 
> is that a typo in the attribute "className"? Do you really mean "org.
> compnay" or instead "org.company"?
> 
> Regards, Janko
> 
> Carver wrote:
>> hi,
>> 
>> I try to define a custom valve in config.xml by the following XML
>> fragment:
>> 
>> <gbean gbeanInfo="org.apache.geronimo.tomcat.ValveGBean"
>> name="geronimo/tomcat/1.1.1/car?ServiceModule=geronimo/tomcat/1.1.1/car,j2eeType=TomcatValve,name=SecondValve">
>> <attribute name="className">org.compnay.valve.MyValve</attribute>
>> <attribute name="initParams">debug=1</attribute>
>> </gbean>
>> <gbean name="TomcatHost">
>> <reference name="TomcatValveChain"/>
>> </gbean>
>> <gbean name="FirstValve">
>> <reference name="NextValve">
>> <pattern>
>> <name>SecondValve</name>
>> </pattern>
>> </reference>
>> </gbean>
>> 
>> The custom valve cannot start since the valve class not found. But I
>> don't
>> know how to import the third-party classes in the config.xml.
>> 
>> Anyone know how to import the third-party classes?
>> 
>> many thanks
>> carver
>> 
>> 
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Problem-with-defining-custom-Valve-in-config.xml-tf4486628s134.html#a12801371
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.


Mime
View raw message