geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul McMahan <paulmcma...@gmail.com>
Subject Re: Geronimo console hangs on failed installation of pluto-portal
Date Thu, 09 Aug 2007 17:51:18 GMT
I think it would be a good idea to create a JIRA and if possible  
attach a minimal WAR that demonstrates the problem.  The console  
should not hang when an app fails to deploy.    While that is looked  
into you may want to consider using the command line for deploying  
since it provides better diagnostic feedback in this case.  bin/ 
depoy.sh deploy pluto.war

Best wishes,
Paul


On Aug 9, 2007, at 5:33 AM, Beelen, M. - SPLXL wrote:

> Hello all,
>
> I'm trying to get the pluto-portal (1.1.4) running on geronimo
> (geronimo-tomcat6-jee5-2.0-M6).
> I installed all the dependancies to the common libs of geronimo,  
> written
> a geronimo-deployment plan and try to upload my war-file.
>
> The browser just hangs.
>
> In the console of the geronimo-server (and the geronimo.log) I see  
> that
> the problem is being caused by some problem in a tld-file nested in a
> jar-file being loaded from the WEB-INF\lib of the portal-webapp. (See
> logging attached below)
> This problem isn't the concern of geronimo, but it causes a
> NoClassDefFoundError for org/saxpath/SAXPathException.
>
> To my knowledge the class has been moved to
> org.jaxen.saxpath.SAXPathException.
> Somehow some component still references the old class-file.
>
> I think it is weird that geronimo hangs on such a problem, instead of
> properly reporting the nature of faillure of the deployment.
>
> I'm forgetting something?
> Does anybody know if I'm doing something wrong or is the problem
> somewhere within geronimo and should I file a jira-issue for this?
>
>
> With kind regards,
>     Marco Beelen


Mime
View raw message