geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevan Miller <kevan.mil...@gmail.com>
Subject Re: [v1.1.1] Classloader problem
Date Fri, 24 Aug 2007 18:01:06 GMT

On Aug 24, 2007, at 3:56 AM, Damien Barthe wrote:

>
> Yeah, it works!
> many thanks mr jencks :-)
>
> For the problem with the v2 of Geronimo, Kevan Miller said what it  
> happens.
> We will try here further test to deploy the app on it.

Glad to hear you got 1.1.1 working, Damien.

There are a several of issues with this example on G 2.0.1.

First, you need to use a server configured with Axis2 as the Web  
Service provider (this is the default with our Tomcat-based assembly  
the Jetty-based assembly can be configured to use Axis2, also). I'm  
working on getting the CXF conflicts resolved.

Second, there appears to be a Spring bug which is causing deployment  
errors. Spring 2.0.4 doesn't have the bug, but 2.0.5 and all later  
2.0.x versions of Spring do. I've raised a Spring Jira --  http:// 
opensource.atlassian.com/projects/spring/browse/SPR-3799. If you  
download Spring 2.0.4 and replace the spring jars in the ear with those

Even after I get the app deployed, it's not working for me. Not sure  
if I've done something wrong... Will be looking at it some more this  
afternoon...

--kevan


Mime
View raw message