geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bgbraga <bgbr...@gmail.com>
Subject Re: Deploy with datasource Error
Date Fri, 17 Aug 2007 01:33:00 GMT

	
I really do not know what I'm making… hehe
I'm following this documentation:
http://cwiki.apache.org/GMOxDOC12/geronimo-applicationxml.html
	
In this link only has one module (exactly for datasource).

What I want is to execute the application for the Eclipse (using WTP).

I am not creating a EAR...

I go to try to create datasource using Administration and leave reference in
geronimo-web.xml.

In this in case, still necessary of application.xml and
geronimo-application.xml?

thanks


djencks wrote:
> 
> I'm not sure what you are trying to do.  the plans you show below  
> indicate that you intend to construct an ear that contains only one  
> module, tranql-connector-1.3.rar.  However I doubt this is what you  
> want to  do.
> 
> Another possibility is that you have a web app that uses a  
> datasource.  In that case the simplest solution is to deploy the  
> datasource using the admin console, and add the datasource config as  
> a dependency in the geronimo-web.xml for the web app.
> 
> It's also possible to construct a "sythentic ear" plan so you end up  
> with only one configuration, but that's a bit more complicated.  If  
> you really want to do that consult the udd server plans under configs  
> in the geronimo source.
> 
> thanks
> david jencks
> 
> On Aug 16, 2007, at 4:35 PM, bgbraga wrote:
> 
>>
>> I'm not having success when making deploy in the Geronimo 2.0 M6
>>
>> I'm user of Tomcat and Websphere Application Server. I never had  
>> used the
>> Geronimo.
>>
>> I read that I would need a Deployment plans, and made these archives:
>> - /META-INF/application.xml
>> - /META-INF/geronimo-application.xml
>> - /WEB-INF/geronimo-web.xml
>> - /geronimo-database.xml (datasource config)
>>
>> DEPLOY ERROR:
>> 20:29:32,341 ERROR [Deployer] Deployment failed due to
>> org.apache.geronimo.common.DeploymentException: Invalid moduleFile:
>> tranql-connector-ra-1.3.rar
>> ....
>> Caused by: java.io.IOException: Jar entry does not exist:
>> jarFile=C:\Users\BRUNO~1.BRA\AppData\Local\Temp\geronimo- 
>> deployer52299.tmpdir\globalsafe.zip,
>> path=tranql-connector-ra-1.3.rar
>>
>>
>>
>> application.xml:
>>
>> <?xml version="1.0" encoding="UTF-8"?>
>> <application
>> 		xmlns="http://java.sun.com/xml/ns/j2ee"
>> 		xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>> 		xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee
>> http://java.sun.com/xml/ns/j2ee/application_1_4.xsd"
>> 		version="1.4">
>>
>> 	<module>
>> 		<connector>tranql-connector-ra-1.3.rar</connector>
>> 	</module>
>> </application>
>>
>>
>> geronimo-application.xml:
>>
>> <?xml version="1.0"?>
>> <application xmlns="http://geronimo.apache.org/xml/ns/j2ee/ 
>> application">
>> 	<dep:environment xmlns:dep="http://geronimo.apache.org/xml/ns/ 
>> deployment">
>> 		<dep:moduleId>
>> 			<dep:groupId>default</dep:groupId>
>> 			<dep:artifactId>GlobalSafe</dep:artifactId>
>> 			<dep:version>1.0</dep:version>
>> 			<dep:type>car</dep:type>
>> 		</dep:moduleId>
>> 		<dep:dependencies/>
>> 		<dep:hidden-classes/>
>> 		<dep:non-overridable-classes/>
>> 	</dep:environment>
>> 	<module>
>> 		<connector>tranql-connector-ra-1.3.rar</connector>
>> 		<alt-dd>geronimo-database.xml</alt-dd>
>> 	</module>
>> </application>
>>
>> How to resolve the problem?
>> <connector>tranql-connector-ra-1.3.rar</connector> and
>> <connector>tranql-connector-1.2.rar</connector> don't work.
>>
>> Thanks!
>>
>> -- 
>> View this message in context: http://www.nabble.com/Deploy-with- 
>> datasource-Error-tf4282757s134.html#a12191411
>> Sent from the Apache Geronimo - Users mailing list archive at  
>> Nabble.com.
>>
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Deploy-with-datasource-Error-tf4282757s134.html#a12192137
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.


Mime
View raw message