You might try setting the "mail.debug" property in the Geronimo mail session configuration to see what the traffic between the client and the server look like. Also, please include the version of Geronimo you're running with, as potential solutions can differ with the version involved. Rick ASHOK PORALU wrote: > Hi, > > I am using Apache Geronimo's default JavaMail session and Apache > JAMES smtp server to send mails from my application. As per JSP code > I am able see the result as message sent but I have not received any > mails to destination mail account. > > Here is the JSP code. > > <%@page import="java.util.Date, > javax.mail.Message, > javax.mail.Session, > javax.mail.Transport, > javax.mail.internet.InternetAddress , > javax.mail.internet.MimeMessage, > javax.naming.InitialContext" %> > > <% > String resultMsg = ""; > String action = request.getParameter("action"); > if ("Send".equals(action)) { > String from = request.getParameter("from"); > String to = request.getParameter("to"); > String subject = request.getParameter ("subject"); > String content = request.getParameter("message"); > > // Get mail session and transport > InitialContext context = new InitialContext(); > // Mail session from web.xml's resource reference > Session mailSession = (Session) > context.lookup("java:comp/env/mail/testMailSession"); > Transport transport = mailSession.getTransport("smtp"); > > // Setup message > MimeMessage message = new MimeMessage(mailSession); > // From address > message.setFrom(new InternetAddress(from)); > // To address > message.addRecipient (Message.RecipientType.TO > , new InternetAddress(to)); > // Subject > message.setSubject (subject); > // Content > message.setText(content); > > // Send message > transport.connect(); > transport.send(message); > > // Build result message > resultMsg = "Result:"; > resultMsg += "
Message sent: " + new Date(); > resultMsg += "
To: " + to; > resultMsg += "
From: " + from; > } > %> > > > > Send Mail > > >
> > > > > > > > > > > > > > > > > > > > > > > > >
Send Mail
From:
To:
Subject:
Message:
> value="Send"> 
>
> <%= resultMsg %> > > > > Can anyone provide advice or solution to this case. I appreciate your > help. > > Thanks in advance > > regards, > Ashok