geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "becky smith" <beck...@gmail.com>
Subject Re: trying to add dependency to exported car
Date Wed, 18 Jul 2007 18:47:41 GMT
Thanks Paul. I think that the problem is occurring because the
config.serfile isn't up-to-date with the new dependencies..

I'm on geronimo tomcat-minimal from trunk (revision 556055), with the latest
from sandbox/portals. My geronimo-plugin looks like this (the bolded line is
the activemq-broker dependency that I added):

<?xml version="1.0" encoding="UTF-8"?>
<geronimo-plugin xmlns=" http://geronimo.apache.org/xml/ns/plugins-1.2">
<name>org.apache.geronimo.configs
/jms-portlets-tomcat/2.0-SNAPSHOT/car</name>
<module-id>org.apache.geronimo.configs/jms-portlets-tomcat/2.0-SNAPSHOT/car</module-id>

<category>portals</category>
<description>Please provide a description</description>
<url></url>
<author></author>
<geronimo-versions>
<version> 2.0-SNAPSHOT</version>
</geronimo-versions>
<dependency>org.apache.geronimo.portals
/geronimo-console/1.0-SNAPSHOT/war</dependency>
<dependency>org.apache.geronimo.portals/pluto-portal/1.0-SNAPSHOT/war</dependency>

<dependency>org.apache.geronimo.portals
/pluto-container/1.0-SNAPSHOT/car</dependency>
<dependency>org.apache.geronimo.configs/activemq-broker//car</dependency>
<dependency>org.apache.pluto/pluto/1.0.1/jar</dependency>
<dependency>org.apache.geronimo.configs/jasper//car</dependency>
<dependency>org.apache.geronimo.configs/tomcat6//car</dependency>
<obsoletes>org.apache.geronimo.configs/jms-portlets-tomcat//car</obsoletes>
<source-repository>file:/C:/myrepo/</source-repository>
<source-repository>http://geronimo.apache.org/plugins/geronimo-2.0/repository/
</source-repository>
<source-repository>http://people.apache.org/repo/m2-incubating-repository/
</source-repository>
<source-repository>http://www.ibiblio.org/maven2/</source-repository>
</geronimo-plugin>

----------------
and when i install it on the command line, i get this output, which doesn't
include the added dependency:

Finished downloading org.apache.geronimo.configs
/jms-portlets-tomcat/2.0-SNAPSHO
T/car (29894 kB) (100%)

    **** Installation Complete!
    Used existing:
    org.apache.geronimo.portals/geronimo-console/1.0-SNAPSHOT/war
    Used existing:
    org.apache.geronimo.portals/pluto-portal/1.0-SNAPSHOT/war
    Used existing:
    org.apache.geronimo.portals/pluto-container/1.0-SNAPSHOT/car
    Used existing: org.apache.pluto/pluto/1.0.1/jar
    Used existing: org.apache.geronimo.configs/jasper//car
    Used existing: org.apache.geronimo.configs/tomcat6//car

    Downloaded 29894 kB in 10s (2989 kB/s)
    Now starting
    org.apache.geronimo.configs /jms-portlets-tomcat/2.0-SNAPSHOT/car...

    Started
    org.apache.geronimo.configs/jms-portlets-tomcat/2.0-SNAPSHOT/car @
    http://localhost:8080/jms-portlets

----

Thanks! Let me know if you need any more info.

-Becky

On 7/18/07, Paul McMahan <paulmcmahan@gmail.com> wrote:
>
> Beck,   which version of geronimo are you using?   Also can you
> please paste your geronimo-plugin.xml and the ids of the "old"
> dependencies that are incorrectly taking the place of the newer
> dependencies you had intended?  Any further diagnostic info you have
> could help as well, such as the output from the plugin installation.
>
>
> Best wishes,
> Paul
>
>
>
>
> On Jul 18, 2007, at 2:00 PM, becky smith wrote:
>
> > Hi,
> >
> > I am trying to add a new dependency to a plugin (.car file) when
> > exporting it through the console. I added the dependency in the
> > dependency box on the console, but when I installed the modified
> > plugin it still loaded the old dependencies. I had the same problem
> > when I manually edited the geronimo-plugin.xml file. Does anyone know
> > why this is happening?
> >
> > Thanks,
> > Becky
>
>

Mime
View raw message