geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rodrigo Rodrigues da Silva" <rodrigopita...@gmail.com>
Subject Re: Server state issues
Date Tue, 24 Jul 2007 13:57:00 GMT
Sachin,

You mean if the remote server is started and I click "Start" it should
connect to it and display a "Started" status or should I wait for it to
automatically update the server status?

thanks,

Rodrigo R. Silva

On 7/24/07, Sachin Patel <sppatel2@gmail.com> wrote:
>
> Shiva,
>
> You can't start a remote server that is stopped.  "Start" from a
> remote server perspective means just connecting to it.  But it has to
> be started outside of eclipse.  If the remote server is stopped then
> pressing start will just attempt to connect several times and then fail.
>
>
> On Jul 24, 2007, at 7:24 AM, Shiva Kumar H R wrote:
>
> > Some more testing and I have hit one problem. "Start" of remote
> > server from inside of Eclipse fails.
> >
> > In my earlier testing, I had started the remote server manually and
> > upon adding it in Eclipse, (after a while) its state changed to
> > "Started". And I was able to deploy/redeploy/undeploy & stop the
> > server. However once the server is stopped (either from within
> > Eclipse or outside), I am not able to Start the Remote Server from
> > inside of Eclipse.
> >
> > I tried this with Geronimo Eclipse Plug-in v2.0 (on Eclipse v3.3 +
> > WTP v2.0) with Geronimo 2.0, and here too I am not able to "Start"
> > the Remote Server from inside of Eclipse. Opened a bug report
> > ( https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-177) for
> > the same. Thanks for raising this discussion.
> >
> > Between, are you able to manually start the remote server and see
> > its status getting changed to "Started" inside Eclipse?
> >
> > - Shiva
> >
> > On 7/24/07, Shiva Kumar H R <shivahr@gmail.com> wrote: Alright I
> > tried what you asked for - Remote deployment to Geronimo 1.1
> > (geronimo-tomcat-j2ee-1.1.zip is what I tried) from within "Eclipse
> > v3.2.1 + WTP v1.5.2 + Geronimo Eclipse Plug-in v1.2.1" and it works
> > correctly. (My local and remote machines run on Windows XP on
> > Intel-32 processor).
> >
> > I followed similar steps as in http://www.ibm.com/developerworks/
> > java/library/os-ag-remotedeploy/index.html . First added a local
> > server and then added a remote server (as in Figure 4 & Figure 5 in
> > that article). Then tried deploying a simple web app to the remote
> > server and it was successful. Modified web app and then chose
> > 'Publish' on remote server and re-deploy was successful, and I
> > could see the changes reflected in browser.
> >
> > What errors do you face?
> >
> > - Shiva
> >
> >
> > On 7/24/07, Rodrigo Rodrigues da Silva <rodrigopitanga@gmail.com >
> > wrote:Hii,
> >
> > I think there might be a problem with the plugin specifically on
> > amd64. I just installed wtp 1.5.4 and the geronimo plugin 1.2.1 on
> > a i386 linux and the local deployment and start/stop server worked!
> > Although, when it comes to remote servers, nothing works yet.
> >
> > Here (http://www.ibm.com/developerworks/java/library/os-ag-
> > remotedeploy/index.html ) it is said that remote deployment
> > directly from eclipse ( i.e, just click on publish button) is as
> > simple as local deployment on geronimo 1.0.
> > But from here ( https://bugs.eclipse.org/bugs/show_bug.cgi?
> > id=150690 ) i might say it is impossible and nothing is being done
> > at the moment as the bug has a WONTFIX resolution.
> >
> > So, the big question is: does remote deployment directly from
> > eclipse work with geronimo 1.1 and g-eclipse 1.2.1?
> >
> > thanks,
> >
> > Rodrigo R. Silva
> >
> >
> > On 7/23/07, Rodrigo Rodrigues da Silva < rodrigopitanga@gmail.com >
> > wrote:Hi,
> >
> > I've managed to install the daily 1.2.1 driver deploying it
> > directly into eclipse tree, but it still doesn't work. The server
> > still remains in "Starting..." state until it fails. Looking
> > through some lists and release notes, I figured out it's been a
> > frequent issue in geronimo. It's said to have been fixed in 1.2.0
> > and 1.2.1 (again?) but unfortunately doesn't work here.
> > The server state for remote servers isn't updated as well. I'd
> > appreciate if someone could clarify me if it really works, as some
> > people told me they thought this feature simply didn't exist.
> >
> > thanks,
> >
> > Rodrigo
> >
> >
> > On 7/23/07, Rodrigo Rodrigues da Silva < rodrigopitanga@gmail.com>
> > wrote: Hi,
> >
> > I am relatively new to Apache Geronimo. I am implementing a
> > software engineering lab project at the university and chose
> > Geronimo as an application server. I have downloaded and installed
> > the Geronimo Plugin for Eclipse 1.2.0 through update manager. I am
> > running Geronimo 1.1.1 on a i386-debian-4.0r0 and Eclipse SDK 3.2.2
> > with WST 1.5.4 (from update manager) on an amd64 with Ubuntu 7.04
> > (eclipse installed from repositories) and Sun Java 5 JVM (also from
> > repositories).
> >
> > There are two issues I've been facing, which are:
> >
> > 1. The local server won't start from inside the IDE. It actually
> > starts but remains in "Starting..." state after a successful
> > startup. After several minutes, Eclipse returns a fail message. I
> > have seen some issues alike reported on this list, but the possible
> > solution (install 1.2.1 plugin) didn't work. I downloaded the daily
> > 1.2.1 driver from devtools site but unzipping it to the plugins/
> > features directories was effectless (there was no "Geronimo"
> > runtime available). The worst thing is that this bug seemed to have
> > been resolved on 1.2.0 as I could read from its release notes.
> > Another fact is that starting a local server worked at a faculty
> > machine running Windows 2k.
> >
> > 2. The server state won't reflect the real server state when one
> > geronimo instance is started from outside the IDE (as I could read
> > on IBM developerWorks papers, it should). I have tried with remote
> > and local instances of geronimo. Therefore I couldn't deploy
> > applications through eclipse, as the servers were in "Stopped"
> > state and Eclipse tried to start them, thereafter failing as they
> > were already started from outside. This wouldn't work in windows 2k
> > as well.
> >
> > I would appreciate if someone could help me, as this environment
> > setup issues are delaying our project.
> >
> > My best regards,
> >
> > Rodrigo R. Silva
> > University of São Paulo
> >
> > --
> > Rodrigo Rodrigues da Silva
> > Engenharia de Computação - Coop8
> > http://www.coop8.rg.com.br
> > Grêmio Politécnico - Gestão Colabora
> > http://www.gremio.poli.usp.br
> >
> > "Não importa como morre o home, importa como vive." Carijó, velho
> > do rio.
> >
> > "To the person with only a hammer, everything looks like a nail."
> > bussdriver
> >
> >
> >
> > --
> > Rodrigo Rodrigues da Silva
> > Engenharia de Computação - Coop8
> > http://www.coop8.rg.com.br
> > Grêmio Politécnico - Gestão Colabora
> > http://www.gremio.poli.usp.br
> >
> > "Não importa como morre o home, importa como vive." Carijó, velho
> > do rio.
> >
> > "To the person with only a hammer, everything looks like a nail."
> > bussdriver
> >
> >
> >
> > --
> > Rodrigo Rodrigues da Silva
> > Engenharia de Computação - Coop8
> > http://www.coop8.rg.com.br
> > Grêmio Politécnico - Gestão Colabora
> > http://www.gremio.poli.usp.br
> >
> > "Não importa como morre o home, importa como vive." Carijó, velho
> > do rio.
> >
> > "To the person with only a hammer, everything looks like a nail."
> > bussdriver
> >
> >
>
>


-- 
Rodrigo Rodrigues da Silva
Engenharia de Computação - Coop8
http://www.coop8.rg.com.br
Grêmio Politécnico - Gestão Colabora
http://www.gremio.poli.usp.br

"Não importa como morre o home, importa como vive." Carijó, velho do rio.

"To the person with only a hammer, everything looks like a nail." bussdriver

Mime
View raw message