geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rodrigo Rodrigues da Silva" <rodrigopita...@gmail.com>
Subject Re: Server state issues
Date Mon, 23 Jul 2007 19:05:07 GMT
Hi,

I've managed to install the daily 1.2.1 driver deploying it directly into
eclipse tree, but it still doesn't work. The server still remains in
"Starting..." state until it fails. Looking through some lists and release
notes, I figured out it's been a frequent issue in geronimo. It's said to
have been fixed in 1.2.0 and 1.2.1 (again?) but unfortunately doesn't work
here.
The server state for remote servers isn't updated as well. I'd appreciate if
someone could clarify me if it really works, as some people told me they
thought this feature simply didn't exist.

thanks,

Rodrigo

On 7/23/07, Rodrigo Rodrigues da Silva <rodrigopitanga@gmail.com> wrote:
>
> Hi,
>
> I am relatively new to Apache Geronimo. I am implementing a software
> engineering lab project at the university and chose Geronimo as an
> application server. I have downloaded and installed the Geronimo Plugin for
> Eclipse 1.2.0 through update manager. I am running Geronimo 1.1.1 on a
> i386-debian-4.0r0 and Eclipse SDK 3.2.2 with WST 1.5.4 (from update
> manager) on an amd64 with Ubuntu 7.04 (eclipse installed from
> repositories) and Sun Java 5 JVM (also from repositories).
>
> There are two issues I've been facing, which are:
>
> 1. The local server won't start from inside the IDE. It actually starts
> but remains in "Starting..." state after a successful startup. After several
> minutes, Eclipse returns a fail message. I have seen some issues alike
> reported on this list, but the possible solution (install 1.2.1 plugin)
> didn't work. I downloaded the daily 1.2.1 driver from devtools site but
> unzipping it to the plugins/features directories was effectless (there was
> no "Geronimo" runtime available). The worst thing is that this bug seemed to
> have been resolved on 1.2.0 as I could read from its release notes.
> Another fact is that starting a local server worked at a faculty machine
> running Windows 2k.
>
> 2. The server state won't reflect the real server state when one geronimo
> instance is started from outside the IDE (as I could read on IBM
> developerWorks papers, it should). I have tried with remote and local
> instances of geronimo. Therefore I couldn't deploy applications through
> eclipse, as the servers were in "Stopped" state and Eclipse tried to start
> them, thereafter failing as they were already started from outside. This
> wouldn't work in windows 2k as well.
>
> I would appreciate if someone could help me, as this environment setup
> issues are delaying our project.
>
> My best regards,
>
> Rodrigo R. Silva
> University of São Paulo
>
> --
> Rodrigo Rodrigues da Silva
> Engenharia de Computação - Coop8
> http://www.coop8.rg.com.br
> Grêmio Politécnico - Gestão Colabora
> http://www.gremio.poli.usp.br
>
> "Não importa como morre o home, importa como vive." Carijó, velho do rio.
>
> "To the person with only a hammer, everything looks like a nail."
> bussdriver




-- 
Rodrigo Rodrigues da Silva
Engenharia de Computação - Coop8
http://www.coop8.rg.com.br
Grêmio Politécnico - Gestão Colabora
http://www.gremio.poli.usp.br

"Não importa como morre o home, importa como vive." Carijó, velho do rio.

"To the person with only a hammer, everything looks like a nail." bussdriver

Mime
View raw message