geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul McMahan <paulmcma...@gmail.com>
Subject Re: Losing my mind
Date Wed, 11 Jul 2007 02:48:29 GMT

On Jul 10, 2007, at 5:15 PM, Arinté wrote:

>         <dependencies>
>             <dependency>
>                 <groupId>org.apache.myfaces.core</groupId>
>                 <artifactId>myfaces-api</artifactId>
>                 <type>jar</type>
>             </dependency>
>             <dependency>
>                 <groupId>org.apache.myfaces.core</groupId>
>                 <artifactId>myfaces-impl</artifactId>
>                 <type>jar</type>
>             </dependency>
>         </dependencies>
>     </environment>

In java ee5 jsf is provided by the container so you don't need to  
include these dependencies.

> It deploys fine, but the jsf stuff isn't looked at at all.  When I  
> view the webpage its blank.  When I right-click and do view source  
> I have this
> <?xml version="1.0" encoding="ISO-8859-1" ?>
>
> <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"  
> "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
> <html xmlns="http://www.w3.org/1999/xhtml"
>     xmlns:f="http://java.sun.com/jsf/core"
>     xmlns:h="http://java.sun.com/jsf/html">
> <head>
> <meta http-equiv="Content-Type" content="text/html;  
> charset=ISO-8859-1" />
> <title>Insert 3</title>
> </head>
> <body>
>
> <f:view>
>     <h:form>
>         <h:selectOneMenu id="subscriptions">
>             <f:selectItem id="item1" itemLabel="News" itemValue="1" />
>             <f:selectItem id="item2" itemLabel="Sports"  
> itemValue="2" />
>             <f:selectItem id="item3" itemLabel="Music"  
> itemValue="3" />
>             <f:selectItem id="item4" itemLabel="Java" itemValue="4" />
>             <f:selectItem id="item5" itemLabel="Web" itemValue="5" />
>         </h:selectOneMenu>
>         <h:commandButton></h:commandButton>
>     </h:form>
> </f:view>
> </body>
> </html>
>
> HELP!?!?!?!?


If that's what you see in your browser then the jsf tags aren't being  
interpreted, which implies that you did not add the FacesServlet to  
your web.xml.   See the bottom of this file for an example:
http://myfaces.apache.org/cardemoweb.html



Best wishes,
Paul



Mime
View raw message