geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Petersson <pe...@pmb.mine.nu>
Subject Re: Strange memory problems / white screens
Date Thu, 19 Jul 2007 15:15:00 GMT
Someone is probably going to as you this so I might as well ;)

What version of Geronimo are you running ?
What jdk version?
Is there a Apache server involved via mod_jk ?
Is it one G deployed application in particular that you notice the 
problem in?
Is there other G deployed apps?
 

At my work we run a G v1.1.1 server and have several Geronimo deployed 
applications with occasionally somewhat heavy load without any memory 
leaks in G (months of uptime) so if this is the version you are using I 
would start looking at the deployed applications memory handling.
Is there a steady increase of memory usage?  you can look at the 
Information page to keep track at it. If this is the case some of your 
deployed applications may leak memory as the garbage collector cant 
release some resources (like open database connections holding on to 
it), tailing good logging output could help locating the problem.

regards
   Peter Petersson
 

Ian Hunter wrote:
>
> We've noticed a problem where intermittently Geronimo starts failing 
> to respond to web requests (browser symptom is a blank white screen) 
> -- when this starts happening, we notice that on the system info tab, 
> the memory metrics display "Not Yet Available" but after we restart 
> Geronimo completely, web requests work and the memory values display.
>
>  
>
> Has anyone else seen anything like this?
>
>  
>
> _______________________________
> **Ian Hunter**
> **Solution Architect**
>
> 925 Northpoint Parkway, Suite 430
> Alpharetta, GA 30005
>
> 678.990.7416 **office**
> 770.754.4264 **fax**
> 404.314.8693 **mobile**
>
>  
>


Mime
View raw message