geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Francisco Borges <franci...@x-hive.com>
Subject allocating Connection using ConnectionRequestInfo: failure testing
Date Mon, 09 Jul 2007 15:13:13 GMT
Hello,

I have some code that uses ConnectionRequestInfo objects to get 
connections, and also some tests for it. They all work on JBoss, but on 
Geronimo1.2, things don't *fail* as I expect.

Namely, I expected that when asking for a connection using an invalid 
ConnectionRequestInfo, to get an "javax.resource.spi.SecurityException" 
thrown, or at least an "javax.resource.ResourceException":

http://geronimo.apache.org/api/org/apache/geronimo/connector/outbound/AbstractConnectionManager.html

Is this expectation wrong? If so, how should I check for a failed request?

I've tried deploying the connection both with <match-one/> and 
<match-all/>:

======
   <outbound-resourceadapter>
         <connection-definition>
[.....]            
               <connectionmanager>
                  <xa-transaction>
                     <transaction-caching/>
                  </xa-transaction>
                  <single-pool>
                     <min-size>0</min-size>
                     <match-one/>
                  </single-pool>
               </connectionmanager>
[....]
   </outbound-resourceadapter>
======

But on both cases, I get no exceptions. 

Comments & hints are heartily welcome,
Cheers,
-- 
Francisco Borges

Mime
View raw message